summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/fix-rpath-in-makefile.patch22
-rw-r--r--debian/patches/series2
-rw-r--r--debian/patches/spelling-mistakes.diff22
3 files changed, 46 insertions, 0 deletions
diff --git a/debian/patches/fix-rpath-in-makefile.patch b/debian/patches/fix-rpath-in-makefile.patch
new file mode 100644
index 0000000..9b043ab
--- /dev/null
+++ b/debian/patches/fix-rpath-in-makefile.patch
@@ -0,0 +1,22 @@
+From: Lasse Flygenring-Harrsen <Lasse@Flygenring-Harrsen.com>
+Date: Wed, 1 Jul 2020 13:52:24 +0200
+Subject: fix-rpath-in-makefile
+
+Avoid changing the runtime search path for the binary, which is not necessary since the binary is statically linked.
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: cava-alsa/Makefile.am
+===================================================================
+--- cava-alsa.orig/Makefile.am 2020-07-01 14:04:17.405510966 +0200
++++ cava-alsa/Makefile.am 2020-07-01 14:05:54.364797434 +0200
+@@ -11,7 +11,7 @@
+ bin_PROGRAMS = cava
+ cava_SOURCES = cava.c config.c input/common.c input/fifo.c input/shmem.c \
+ output/terminal_noncurses.c output/raw.c
+-cava_LDFLAGS = -L/usr/local/lib -Wl,-rpath /usr/local/lib
++cava_LDFLAGS = -L/usr/local/lib
+ cava_CPPFLAGS = -DPACKAGE=\"$(PACKAGE)\" -DVERSION=\"$(VERSION)\" \
+ -D_POSIX_SOURCE -D _POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE_EXTENDED
+ cava_CFLAGS = -std=c99 -Wall -Werror -Wextra -Wno-unused-result -Wno-unknown-warning-option -Wno-maybe-uninitialized
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..adf0fc3
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+fix-rpath-in-makefile.patch
+spelling-mistakes.diff
diff --git a/debian/patches/spelling-mistakes.diff b/debian/patches/spelling-mistakes.diff
new file mode 100644
index 0000000..c332b66
--- /dev/null
+++ b/debian/patches/spelling-mistakes.diff
@@ -0,0 +1,22 @@
+From: Lasse Flygenring-Harrsen <Lasse@Flygenring-Harrsen.com>
+Date: Wed, 1 Jul 2020 13:52:24 +0200
+Subject: spelling-mistakes
+
+Fixed spelling mistake 'quiting' instead of 'quitting', which ended up in the binary.
+---
+ cava.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cava.c b/cava.c
+index 45ec0c3..8ee0043 100644
+--- a/cava.c
++++ b/cava.c
+@@ -473,7 +473,7 @@ as of 0.4.0 all options are specified in config file, see in '/home/username/.co
+ if (n > 2000) {
+ cleanup();
+ fprintf(stderr, "could not get rate and/or format, problems with audio thread? "
+- "quiting...\n");
++ "quitting...\n");
+ exit(EXIT_FAILURE);
+ }
+ }