summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorShehzan Mohammed <shehzan@arrayfire.com>2016-10-13 12:03:44 -0400
committerShehzan Mohammed <shehzan@arrayfire.com>2016-10-13 12:03:44 -0400
commit56f07e42b1734fdebefadea6405f4d2838f65190 (patch)
treefff8a907772d7f3e889525082c428927e33807c1
parent115af8c78ed93894b1e3021d9612df89d2cef3d4 (diff)
Add option to build shared or static library
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 178ac9bb..b422743f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,7 @@ set(clblast_VERSION_MINOR 9)
set(clblast_VERSION_PATCH 0)
# Options and their default values
+option(BUILD_SHARED_LIBS "Build shared or static library" ON)
option(SAMPLES "Enable compilation of the examples" OFF)
option(TUNERS "Enable compilation of the tuners" OFF)
option(CLIENTS "Enable compilation of the clients to test and compare performance" OFF)
@@ -171,7 +172,12 @@ foreach(ROUTINE ${LEVELX_ROUTINES})
endforeach()
# Creates and links the library
-add_library(clblast SHARED ${SOURCES})
+if(BUILD_SHARED_LIBS)
+ add_library(clblast SHARED ${SOURCES})
+else(BUILD_SHARED_LIBS)
+ add_library(clblast STATIC ${SOURCES})
+endif(BUILD_SHARED_LIBS)
+
target_link_libraries(clblast ${OPENCL_LIBRARIES})
# Includes directories: CLBlast and OpenCL