summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2016-10-25 20:33:10 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2016-10-25 20:33:10 +0200
commit8ae8ab06a2b6f24faa0de5d390a5ae272aa94c23 (patch)
treea5956e19e79bf15c25d966d58c01b69ae9ac5d56
parent140121ef91cc13892711f57da0d046f88cf55301 (diff)
Renamed the include and source files of the Netlib CBLAS API
-rw-r--r--CMakeLists.txt4
-rw-r--r--include/clblast_netlib_c.h (renamed from include/clblast_blas.h)6
-rwxr-xr-xscripts/generator/generator.py12
-rw-r--r--scripts/generator/generator/cpp.py4
-rw-r--r--src/clblast_netlib_c.cpp (renamed from src/clblast_blas.cpp)2
5 files changed, 14 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1fff1a3a..aa1e287e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -170,7 +170,7 @@ set(SOURCES
src/cache.cpp
src/clblast.cpp
src/clblast_c.cpp
- src/clblast_blas.cpp
+ src/clblast_netlib_c.cpp
src/routine.cpp
)
foreach(ROUTINE ${LEVEL1_ROUTINES})
@@ -214,7 +214,7 @@ install(TARGETS clblast EXPORT CLBlast DESTINATION lib)
install(FILES include/clblast.h DESTINATION include)
install(FILES include/clblast_c.h DESTINATION include)
install(FILES include/clblast_half.h DESTINATION include)
-install(FILES include/clblast_blas.h DESTINATION include)
+install(FILES include/clblast_netlib_c.h DESTINATION include)
# Installs the config for find_package in dependent projects
install(EXPORT CLBlast DESTINATION lib/cmake/CLBLast FILE CLBlastConfig.cmake)
diff --git a/include/clblast_blas.h b/include/clblast_netlib_c.h
index ff560712..c233646e 100644
--- a/include/clblast_blas.h
+++ b/include/clblast_netlib_c.h
@@ -13,8 +13,8 @@
//
// =================================================================================================
-#ifndef CLBLAST_CLBLAST_BLAS_H_
-#define CLBLAST_CLBLAST_BLAS_H_
+#ifndef CLBLAST_CLBLAST_NETLIB_C_H_
+#define CLBLAST_CLBLAST_NETLIB_C_H_
// Exports library functions under Windows when building a DLL. See also:
// https://msdn.microsoft.com/en-us/library/a90k134d.aspx
@@ -924,5 +924,5 @@ void PUBLIC_API cblas_zomatcopy(const CLBlastLayout layout, const CLBlastTranspo
} // extern "C"
#endif
-// CLBLAST_CLBLAST_BLAS_H_
+// CLBLAST_CLBLAST_NETLIB_C_H_
#endif
diff --git a/scripts/generator/generator.py b/scripts/generator/generator.py
index 65d40877..1a467340 100755
--- a/scripts/generator/generator.py
+++ b/scripts/generator/generator.py
@@ -12,8 +12,8 @@
# clblast.cpp
# clblast_c.h
# clblast_c.cpp
-# clblast_blas.h
-# clblast_blas.cpp
+# clblast_netlib_c.h
+# clblast_netlib_c.cpp
# wrapper_clblas.h
# wrapper_cblas.h
# It also generates the main functions for the correctness and performance tests as found in
@@ -38,8 +38,8 @@ FILES = [
"/src/clblast_c.cpp",
"/test/wrapper_clblas.hpp",
"/test/wrapper_cblas.hpp",
- "/include/clblast_blas.h",
- "/src/clblast_blas.cpp",
+ "/include/clblast_netlib_c.h",
+ "/src/clblast_netlib_c.cpp",
]
HEADER_LINES = [117, 73, 118, 22, 29, 41, 47, 32]
FOOTER_LINES = [17, 80, 19, 18, 6, 6, 9, 2]
@@ -205,9 +205,9 @@ def main(argv):
if i == 5:
body += cpp.wrapper_cblas(routine)
if i == 6:
- body += cpp.clblast_blas_h(routine)
+ body += cpp.clblast_netlib_c_h(routine)
if i == 7:
- body += cpp.clblast_blas_cc(routine)
+ body += cpp.clblast_netlib_c_cc(routine)
f.write("".join(file_header))
f.write(body)
f.write("".join(file_footer))
diff --git a/scripts/generator/generator/cpp.py b/scripts/generator/generator/cpp.py
index 60e29a07..9d4ef6c4 100644
--- a/scripts/generator/generator/cpp.py
+++ b/scripts/generator/generator/cpp.py
@@ -95,7 +95,7 @@ def clblast_c_cc(routine):
return result
-def clblast_blas_h(routine):
+def clblast_netlib_c_h(routine):
"""The Netlib CBLAS API header (.h)"""
result = NL + "// " + routine.description + ": " + routine.short_names() + NL
for flavour in routine.flavours:
@@ -104,7 +104,7 @@ def clblast_blas_h(routine):
return result
-def clblast_blas_cc(routine):
+def clblast_netlib_c_cc(routine):
"""The Netlib CBLAS API implementation (.cpp)"""
result = NL + "// " + routine.name.upper() + NL
for flavour in routine.flavours:
diff --git a/src/clblast_blas.cpp b/src/clblast_netlib_c.cpp
index 6cc14583..203a3423 100644
--- a/src/clblast_blas.cpp
+++ b/src/clblast_netlib_c.cpp
@@ -15,7 +15,7 @@
#include <cstdlib>
-#include "clblast_blas.h"
+#include "clblast_netlib_c.h"
#include "clblast.h"
#include "utilities/utilities.hpp"