summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2018-12-04 20:46:02 +0100
committerCedric Nugteren <web@cedricnugteren.nl>2018-12-04 20:46:02 +0100
commit0c9411c84465d14d2de33046536403648909eb9f (patch)
treef8f0bf0cd027a39b6a5ea3e267c7ee12bf2bcc8d
parent09ab5f512f343f54c1b85a7f1abfc5da4c6fcb6e (diff)
Updated to version 1.5.0
-rw-r--r--.appveyor.yml4
-rw-r--r--.travis.yml2
-rw-r--r--CHANGELOG2
-rw-r--r--CMakeLists.txt4
4 files changed, 6 insertions, 6 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index f07f2971..24f20370 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -57,8 +57,8 @@ build_script:
after_build:
- ps: pushd $env:CLBLAST_BUILD
- - 7z a CLBlast-1.4.1-Windows-x64.zip .\install_dir\*
- - ps: mv CLBlast-1.4.1-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
+ - 7z a CLBlast-1.5.0-Windows-x64.zip .\install_dir\*
+ - ps: mv CLBlast-1.5.0-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
artifacts:
- path: '*.zip'
diff --git a/.travis.yml b/.travis.yml
index fc60826c..fab7c875 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -21,7 +21,7 @@ matrix:
env:
global:
- - CLBLAST_VERSION=1.4.1
+ - CLBLAST_VERSION=1.5.0
- CLBLAST_ROOT=${TRAVIS_BUILD_DIR}/bin/clblast
- CLBLAST_INSTALL=${TRAVIS_BUILD_DIR}/bin/CLBlast-${CLBLAST_VERSION}
- CLBLAST_TAR=CLBlast-${CLBLAST_VERSION}-${TRAVIS_OS_NAME}-x64.tar.gz
diff --git a/CHANGELOG b/CHANGELOG
index f84e54b1..2241b855 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,5 +1,5 @@
-Development (next version)
+Version 1.5.0
- Added support for shuffle instructions for NVIDIA GPUs (thanks to 'tyler-utah')
- Added an option to compile the Netlib API with static OpenCL device and context (-DNETLIB_PERSISTENT_OPENCL=ON)
- Added a FAQ page to the documentation
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 80eb9583..fc3101b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,8 +21,8 @@ endif()
# CMake project details
project("clblast" C CXX)
set(clblast_VERSION_MAJOR 1)
-set(clblast_VERSION_MINOR 4)
-set(clblast_VERSION_PATCH 1)
+set(clblast_VERSION_MINOR 5)
+set(clblast_VERSION_PATCH 0)
set(clblast_VERSION "${clblast_VERSION_MAJOR}.${clblast_VERSION_MINOR}.${clblast_VERSION_PATCH}")
set(clblast_SOVERSION ${clblast_VERSION_MAJOR})