summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcnugteren <web@cedricnugteren.nl>2016-04-20 22:12:51 -0600
committercnugteren <web@cedricnugteren.nl>2016-04-20 22:12:51 -0600
commit16a048f1ac8102ad4bcce9cf9fc320f791323e45 (patch)
treebd7df539c92b92cb8841ff27fd83c4e14e5958bc
parent894983fc3c7c57ffc48c21523641694cde318eca (diff)
Added support for the iSAMAX/iDAMAX/iCAMAX/iZAMAX routines
-rw-r--r--CHANGELOG1
-rw-r--r--CMakeLists.txt2
-rw-r--r--README.md2
-rw-r--r--include/internal/routines/level1/xamax.h56
-rw-r--r--include/internal/utilities.h2
-rw-r--r--scripts/generator/generator.py4
-rw-r--r--src/clblast.cc17
-rw-r--r--src/kernels/common.opencl9
-rw-r--r--src/kernels/level1/xamax.opencl128
-rw-r--r--src/routines/level1/xamax.cc112
-rw-r--r--test/correctness/testblas.h12
-rw-r--r--test/performance/client.cc2
-rw-r--r--test/routines/level1/xamax.h139
-rw-r--r--test/wrapper_clblas.h8
14 files changed, 477 insertions, 17 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 9c954761..c9770dc2 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -7,6 +7,7 @@ Development version (next release)
- Added level-1 routines:
* SNRM2/DNRM2/ScNRM2/DzNRM2
* SASUM/DASUM/ScASUM/DzASUM
+ * iSAMAX/iDAMAX/iCAMAX/iZAMAX
Version 0.6.0
- Added support for MSVC (Visual Studio) 2015
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d60dc88..efdf6be0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -121,7 +121,7 @@ include_directories(${clblast_SOURCE_DIR}/include ${OPENCL_INCLUDE_DIRS})
set(KERNELS copy pad transpose padtranspose xaxpy xdot xger xgemm xgemv)
set(SAMPLE_PROGRAMS_CPP sgemm)
set(SAMPLE_PROGRAMS_C sgemm)
-set(LEVEL1_ROUTINES xswap xscal xcopy xaxpy xdot xdotu xdotc xnrm2 xasum)
+set(LEVEL1_ROUTINES xswap xscal xcopy xaxpy xdot xdotu xdotc xnrm2 xasum xamax)
set(LEVEL2_ROUTINES xgemv xgbmv xhemv xhbmv xhpmv xsymv xsbmv xspmv xtrmv xtbmv xtpmv
xger xgeru xgerc xher xhpr xher2 xhpr2 xsyr xspr xsyr2 xspr2)
set(LEVEL3_ROUTINES xgemm xsymm xhemm xsyrk xherk xsyr2k xher2k xtrmm)
diff --git a/README.md b/README.md
index e786cc97..b4f0981f 100644
--- a/README.md
+++ b/README.md
@@ -186,7 +186,7 @@ CLBlast is in active development but already supports almost all the BLAS routin
| xDOTC | - | - | ✔ | ✔ | |
| xNRM2 | ✔ | ✔ | ✔ | ✔ | |
| xASUM | ✔ | ✔ | ✔ | ✔ | |
-| IxAMAX | | | | | |
+| IxAMAX | ✔ | ✔ | ✔ | ✔ | |
| Level-2 | S | D | C | Z | Notes |
| ---------|---|---|---|---|---------|
diff --git a/include/internal/routines/level1/xamax.h b/include/internal/routines/level1/xamax.h
new file mode 100644
index 00000000..b815e8d2
--- /dev/null
+++ b/include/internal/routines/level1/xamax.h
@@ -0,0 +1,56 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file implements the Xamax routine. The precision is implemented using a template argument.
+//
+// =================================================================================================
+
+#ifndef CLBLAST_ROUTINES_XAMAX_H_
+#define CLBLAST_ROUTINES_XAMAX_H_
+
+#include "internal/routine.h"
+
+namespace clblast {
+// =================================================================================================
+
+// See comment at top of file for a description of the class
+template <typename T>
+class Xamax: public Routine<T> {
+ public:
+
+ // Members and methods from the base class
+ using Routine<T>::db_;
+ using Routine<T>::source_string_;
+ using Routine<T>::queue_;
+ using Routine<T>::event_;
+ using Routine<T>::context_;
+ using Routine<T>::GetProgramFromCache;
+ using Routine<T>::TestVectorX;
+ using Routine<T>::TestVectorDot;
+ using Routine<T>::RunKernel;
+ using Routine<T>::ErrorIn;
+
+ // Constructor
+ Xamax(Queue &queue, EventPointer event, const std::string &name = "AMAX");
+
+ // Templated-precision implementation of the routine
+ StatusCode DoAmax(const size_t n,
+ const Buffer<T> &imax_buffer, const size_t imax_offset,
+ const Buffer<T> &x_buffer, const size_t x_offset, const size_t x_inc);
+
+ private:
+ // Static variable to get the precision
+ const static Precision precision_;
+};
+
+// =================================================================================================
+} // namespace clblast
+
+// CLBLAST_ROUTINES_XAMAX_H_
+#endif
diff --git a/include/internal/utilities.h b/include/internal/utilities.h
index 8ffdc3af..75b3d27d 100644
--- a/include/internal/utilities.h
+++ b/include/internal/utilities.h
@@ -66,6 +66,7 @@ constexpr auto kArgAPOffset = "offap";
constexpr auto kArgDotOffset = "offdot";
constexpr auto kArgNrm2Offset = "offnrm2";
constexpr auto kArgAsumOffset = "offasum";
+constexpr auto kArgImaxOffset = "offimax";
constexpr auto kArgAlpha = "alpha";
constexpr auto kArgBeta = "beta";
@@ -121,6 +122,7 @@ struct Arguments {
size_t dot_offset = 0;
size_t nrm2_offset = 0;
size_t asum_offset = 0;
+ size_t imax_offset = 0;
T alpha = T{1.0};
T beta = T{1.0};
size_t x_size = 1;
diff --git a/scripts/generator/generator.py b/scripts/generator/generator.py
index 3a845686..d8bd4e2c 100644
--- a/scripts/generator/generator.py
+++ b/scripts/generator/generator.py
@@ -72,7 +72,7 @@ routines = [
Routine(True, "1", "dotc", T, [C,Z], ["n"], [], ["x","y"], ["dot"], [], "n", "Dot product of two complex vectors, one conjugated"),
Routine(True, "1", "nrm2", T, [S,D,Sc,Dz],["n"], [], ["x"], ["nrm2"], [], "2*n", "Euclidian norm of a vector"),
Routine(True, "1", "asum", T, [S,D,Sc,Dz],["n"], [], ["x"], ["asum"], [], "n", "Absolute sum of values in a vector"),
- Routine(False, "1", "amax", T, [iS,iD,iC,iZ],["n"], [], ["x"], ["imax"], [], "n", "Index of absolute maxium value in a vector"),
+ Routine(True, "1", "amax", T, [iS,iD,iC,iZ],["n"], [], ["x"], ["imax"], [], "2*n", "Index of absolute maxium value in a vector"),
],
[ # Level 2: matrix-vector
Routine(True, "2a", "gemv", T, [S,D,C,Z], ["m","n"], ["layout","a_transpose"], ["a","x"], ["y"], ["alpha","beta"], "", "General matrix-vector multiplication"),
@@ -294,7 +294,7 @@ files = [
path_clblast+"/test/wrapper_clblas.h",
path_clblast+"/test/wrapper_cblas.h",
]
-header_lines = [84, 66, 93, 22, 22, 38]
+header_lines = [84, 67, 93, 22, 22, 38]
footer_lines = [6, 3, 9, 2, 6, 6]
# Checks whether the command-line arguments are valid; exists otherwise
diff --git a/src/clblast.cc b/src/clblast.cc
index bee63b53..145b6bf6 100644
--- a/src/clblast.cc
+++ b/src/clblast.cc
@@ -28,6 +28,7 @@
#include "internal/routines/level1/xdotc.h"
#include "internal/routines/level1/xnrm2.h"
#include "internal/routines/level1/xasum.h"
+#include "internal/routines/level1/xamax.h"
// BLAS level-2 includes
#include "internal/routines/level2/xgemv.h"
@@ -430,11 +431,17 @@ template StatusCode PUBLIC_API Asum<double2>(const size_t,
// Index of absolute maxium value in a vector: iSAMAX/iDAMAX/iCAMAX/iZAMAX
template <typename T>
-StatusCode Amax(const size_t,
- cl_mem, const size_t,
- const cl_mem, const size_t, const size_t,
- cl_command_queue*, cl_event*) {
- return StatusCode::kNotImplemented;
+StatusCode Amax(const size_t n,
+ cl_mem imax_buffer, const size_t imax_offset,
+ const cl_mem x_buffer, const size_t x_offset, const size_t x_inc,
+ cl_command_queue* queue, cl_event* event) {
+ auto queue_cpp = Queue(*queue);
+ auto routine = Xamax<T>(queue_cpp, event);
+ auto status = routine.SetUp();
+ if (status != StatusCode::kSuccess) { return status; }
+ return routine.DoAmax(n,
+ Buffer<T>(imax_buffer), imax_offset,
+ Buffer<T>(x_buffer), x_offset, x_inc);
}
template StatusCode PUBLIC_API Amax<float>(const size_t,
cl_mem, const size_t,
diff --git a/src/kernels/common.opencl b/src/kernels/common.opencl
index 0a68defb..57d75ee0 100644
--- a/src/kernels/common.opencl
+++ b/src/kernels/common.opencl
@@ -80,6 +80,15 @@ R"(
#define ONE 1.0
#endif
+// Single-element version of a complex number
+#if PRECISION == 3232
+ typedef float singlereal;
+#elif PRECISION == 6464
+ typedef double singlereal;
+#else
+ typedef real singlereal;
+#endif
+
// =================================================================================================
// Don't use the non-IEEE754 compliant OpenCL built-in mad() instruction per default. For specific
diff --git a/src/kernels/level1/xamax.opencl b/src/kernels/level1/xamax.opencl
new file mode 100644
index 00000000..03dd05e5
--- /dev/null
+++ b/src/kernels/level1/xamax.opencl
@@ -0,0 +1,128 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file contains the Xamax kernel. It implements an index of absolute max computation using
+// reduction kernels. Reduction is split in two parts. In the first (main) kernel the X vector is
+// loaded, followed by a per-thread and a per-workgroup reduction. The second (epilogue) kernel
+// is executed with a single workgroup only, computing the final result.
+//
+// =================================================================================================
+
+// Enables loading of this file using the C++ pre-processor's #include (C++11 standard raw string
+// literal). Comment-out this line for syntax-highlighting when developing.
+R"(
+
+// Parameters set by the tuner or by the database. Here they are given a basic default value in case
+// this kernel file is used outside of the CLBlast library.
+#ifndef WGS1
+ #define WGS1 64 // The local work-group size of the main kernel
+#endif
+#ifndef WGS2
+ #define WGS2 64 // The local work-group size of the epilogue kernel
+#endif
+
+// =================================================================================================
+
+// The main reduction kernel, performing the loading and the majority of the operation
+__attribute__((reqd_work_group_size(WGS1, 1, 1)))
+__kernel void Xamax(const int n,
+ const __global real* restrict xgm, const int x_offset, const int x_inc,
+ __global singlereal* maxgm, __global unsigned int* imaxgm) {
+ __local singlereal maxlm[WGS1];
+ __local unsigned int imaxlm[WGS1];
+ const int lid = get_local_id(0);
+ const int wgid = get_group_id(0);
+ const int num_groups = get_num_groups(0);
+
+ // Performs loading and the first steps of the reduction
+ singlereal max = ZERO;
+ unsigned int imax = 0;
+ int id = wgid*WGS1 + lid;
+ while (id < n) {
+ #if PRECISION == 3232 || PRECISION == 6464
+ singlereal x = fabs(xgm[id*x_inc + x_offset].x);
+ #else
+ singlereal x = fabs(xgm[id*x_inc + x_offset]);
+ #endif
+ if (x >= max) {
+ max = x;
+ imax = id*x_inc + x_offset;
+ }
+ id += WGS1*num_groups;
+ }
+ maxlm[lid] = max;
+ imaxlm[lid] = imax;
+ barrier(CLK_LOCAL_MEM_FENCE);
+
+ // Performs reduction in local memory
+ #pragma unroll
+ for (int s=WGS1/2; s>0; s=s>>1) {
+ if (lid < s) {
+ if (maxlm[lid + s] >= maxlm[lid]) {
+ maxlm[lid] = maxlm[lid + s];
+ imaxlm[lid] = imaxlm[lid + s];
+ }
+ }
+ barrier(CLK_LOCAL_MEM_FENCE);
+ }
+
+ // Stores the per-workgroup result
+ if (lid == 0) {
+ maxgm[wgid] = maxlm[0];
+ imaxgm[wgid] = imaxlm[0];
+ }
+}
+
+// =================================================================================================
+
+// The epilogue reduction kernel, performing the final bit of the operation. This kernel has to
+// be launched with a single workgroup only.
+__attribute__((reqd_work_group_size(WGS2, 1, 1)))
+__kernel void XamaxEpilogue(const __global singlereal* restrict maxgm,
+ const __global unsigned int* restrict imaxgm,
+ __global unsigned int* imax, const int imax_offset) {
+ __local singlereal maxlm[WGS2];
+ __local unsigned int imaxlm[WGS2];
+ const int lid = get_local_id(0);
+
+ // Performs the first step of the reduction while loading the data
+ if (maxgm[lid + WGS2] >= maxgm[lid]) {
+ maxlm[lid] = maxgm[lid + WGS2];
+ imaxlm[lid] = imaxgm[lid + WGS2];
+ }
+ else {
+ maxlm[lid] = maxgm[lid];
+ imaxlm[lid] = imaxgm[lid];
+ }
+ barrier(CLK_LOCAL_MEM_FENCE);
+
+ // Performs reduction in local memory
+ #pragma unroll
+ for (int s=WGS2/2; s>0; s=s>>1) {
+ if (lid < s) {
+ if (maxlm[lid + s] >= maxlm[lid]) {
+ maxlm[lid] = maxlm[lid + s];
+ imaxlm[lid] = imaxlm[lid + s];
+ }
+ }
+ barrier(CLK_LOCAL_MEM_FENCE);
+ }
+
+ // Stores the final result
+ if (lid == 0) {
+ imax[imax_offset] = imaxlm[0];
+ }
+}
+
+// =================================================================================================
+
+// End of the C++11 raw string literal
+)"
+
+// =================================================================================================
diff --git a/src/routines/level1/xamax.cc b/src/routines/level1/xamax.cc
new file mode 100644
index 00000000..ffdfa496
--- /dev/null
+++ b/src/routines/level1/xamax.cc
@@ -0,0 +1,112 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file implements the Xamax class (see the header for information about the class).
+//
+// =================================================================================================
+
+#include "internal/routines/level1/xamax.h"
+
+#include <string>
+#include <vector>
+
+namespace clblast {
+// =================================================================================================
+
+// Specific implementations to get the memory-type based on a template argument
+template <> const Precision Xamax<float>::precision_ = Precision::kSingle;
+template <> const Precision Xamax<double>::precision_ = Precision::kDouble;
+template <> const Precision Xamax<float2>::precision_ = Precision::kComplexSingle;
+template <> const Precision Xamax<double2>::precision_ = Precision::kComplexDouble;
+
+// =================================================================================================
+
+// Constructor: forwards to base class constructor
+template <typename T>
+Xamax<T>::Xamax(Queue &queue, EventPointer event, const std::string &name):
+ Routine<T>(queue, event, name, {"Xdot"}, precision_) {
+ source_string_ =
+ #include "../../kernels/level1/xamax.opencl"
+ ;
+}
+
+// =================================================================================================
+
+// The main routine
+template <typename T>
+StatusCode Xamax<T>::DoAmax(const size_t n,
+ const Buffer<T> &imax_buffer, const size_t imax_offset,
+ const Buffer<T> &x_buffer, const size_t x_offset, const size_t x_inc) {
+
+ // Makes sure all dimensions are larger than zero
+ if (n == 0) { return StatusCode::kInvalidDimension; }
+
+ // Tests the vectors for validity
+ auto status = TestVectorX(n, x_buffer, x_offset, x_inc, sizeof(T));
+ if (ErrorIn(status)) { return status; }
+ status = TestVectorDot(1, imax_buffer, imax_offset, sizeof(T));
+ if (ErrorIn(status)) { return status; }
+
+ // Retrieves the Xamax kernels from the compiled binary
+ try {
+ auto& program = GetProgramFromCache();
+ auto kernel1 = Kernel(program, "Xamax");
+ auto kernel2 = Kernel(program, "XamaxEpilogue");
+
+ // Creates the buffer for intermediate values
+ auto temp_size = 2*db_["WGS2"];
+ auto temp_buffer1 = Buffer<T>(context_, temp_size);
+ auto temp_buffer2 = Buffer<unsigned int>(context_, temp_size);
+
+ // Sets the kernel arguments
+ kernel1.SetArgument(0, static_cast<int>(n));
+ kernel1.SetArgument(1, x_buffer());
+ kernel1.SetArgument(2, static_cast<int>(x_offset));
+ kernel1.SetArgument(3, static_cast<int>(x_inc));
+ kernel1.SetArgument(4, temp_buffer1());
+ kernel1.SetArgument(5, temp_buffer2());
+
+ // Event waiting list
+ auto eventWaitList = std::vector<Event>();
+
+ // Launches the main kernel
+ auto global1 = std::vector<size_t>{db_["WGS1"]*temp_size};
+ auto local1 = std::vector<size_t>{db_["WGS1"]};
+ auto kernelEvent = Event();
+ status = RunKernel(kernel1, global1, local1, kernelEvent.pointer());
+ if (ErrorIn(status)) { return status; }
+ eventWaitList.push_back(kernelEvent);
+
+ // Sets the arguments for the epilogue kernel
+ kernel2.SetArgument(0, temp_buffer1());
+ kernel2.SetArgument(1, temp_buffer2());
+ kernel2.SetArgument(2, imax_buffer());
+ kernel2.SetArgument(3, static_cast<int>(imax_offset));
+
+ // Launches the epilogue kernel
+ auto global2 = std::vector<size_t>{db_["WGS2"]};
+ auto local2 = std::vector<size_t>{db_["WGS2"]};
+ status = RunKernel(kernel2, global2, local2, event_, eventWaitList);
+ if (ErrorIn(status)) { return status; }
+
+ // Succesfully finished the computation
+ return StatusCode::kSuccess;
+ } catch (...) { return StatusCode::kInvalidKernel; }
+}
+
+// =================================================================================================
+
+// Compiles the templated class
+template class Xamax<float>;
+template class Xamax<double>;
+template class Xamax<float2>;
+template class Xamax<double2>;
+
+// =================================================================================================
+} // namespace clblast
diff --git a/test/correctness/testblas.h b/test/correctness/testblas.h
index aa61c2ec..13be921a 100644
--- a/test/correctness/testblas.h
+++ b/test/correctness/testblas.h
@@ -154,6 +154,7 @@ void RunTests(int argc, char *argv[], const bool silent, const std::string &name
auto dot_offsets = std::vector<size_t>{args.dot_offset};
auto nrm2_offsets = std::vector<size_t>{args.nrm2_offset};
auto asum_offsets = std::vector<size_t>{args.asum_offset};
+ auto imax_offsets = std::vector<size_t>{args.imax_offset};
auto alphas = std::vector<U>{args.alpha};
auto betas = std::vector<U>{args.beta};
auto x_sizes = std::vector<size_t>{args.x_size};
@@ -195,6 +196,7 @@ void RunTests(int argc, char *argv[], const bool silent, const std::string &name
if (option == kArgDotOffset) { dot_offsets = tester.kOffsets; }
if (option == kArgNrm2Offset) { nrm2_offsets = tester.kOffsets; }
if (option == kArgAsumOffset) { asum_offsets = tester.kOffsets; }
+ if (option == kArgImaxOffset) { imax_offsets = tester.kOffsets; }
if (option == kArgAlpha) { alphas = tester.kAlphaValues; }
if (option == kArgBeta) { betas = tester.kBetaValues; }
@@ -236,10 +238,12 @@ void RunTests(int argc, char *argv[], const bool silent, const std::string &name
for (auto &dot_offset: dot_offsets) { r_args.dot_offset = dot_offset;
for (auto &nrm2_offset: nrm2_offsets) { r_args.nrm2_offset = nrm2_offset;
for (auto &asum_offset: asum_offsets) { r_args.asum_offset = asum_offset;
- for (auto &alpha: alphas) { r_args.alpha = alpha;
- for (auto &beta: betas) { r_args.beta = beta;
- C::SetSizes(r_args);
- regular_test_vector.push_back(r_args);
+ for (auto &imax_offset: imax_offsets) { r_args.imax_offset = imax_offset;
+ for (auto &alpha: alphas) { r_args.alpha = alpha;
+ for (auto &beta: betas) { r_args.beta = beta;
+ C::SetSizes(r_args);
+ regular_test_vector.push_back(r_args);
+ }
}
}
}
diff --git a/test/performance/client.cc b/test/performance/client.cc
index f22c9666..9aaf1e4e 100644
--- a/test/performance/client.cc
+++ b/test/performance/client.cc
@@ -84,6 +84,7 @@ Arguments<U> Client<T,U>::ParseArguments(int argc, char *argv[], const GetMetric
if (o == kArgDotOffset) { args.dot_offset = GetArgument(argc, argv, help, kArgDotOffset, size_t{0}); }
if (o == kArgNrm2Offset) { args.nrm2_offset = GetArgument(argc, argv, help, kArgNrm2Offset, size_t{0}); }
if (o == kArgAsumOffset) { args.asum_offset = GetArgument(argc, argv, help, kArgAsumOffset, size_t{0}); }
+ if (o == kArgImaxOffset) { args.imax_offset = GetArgument(argc, argv, help, kArgImaxOffset, size_t{0}); }
// Scalar values
if (o == kArgAlpha) { args.alpha = GetArgument(argc, argv, help, kArgAlpha, GetScalar<U>()); }
@@ -295,6 +296,7 @@ void Client<T,U>::PrintTableRow(const Arguments<U>& args,
else if (o == kArgDotOffset) {integers.push_back(args.dot_offset); }
else if (o == kArgNrm2Offset){integers.push_back(args.nrm2_offset); }
else if (o == kArgAsumOffset){integers.push_back(args.asum_offset); }
+ else if (o == kArgImaxOffset){integers.push_back(args.imax_offset); }
}
auto strings = std::vector<std::string>{};
for (auto &o: options_) {
diff --git a/test/routines/level1/xamax.h b/test/routines/level1/xamax.h
new file mode 100644
index 00000000..7b404dc3
--- /dev/null
+++ b/test/routines/level1/xamax.h
@@ -0,0 +1,139 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file implements a class with static methods to describe the Xamax routine. Examples of
+// such 'descriptions' are how to calculate the size a of buffer or how to run the routine. These
+// static methods are used by the correctness tester and the performance tester.
+//
+// =================================================================================================
+
+#ifndef CLBLAST_TEST_ROUTINES_XAMAX_H_
+#define CLBLAST_TEST_ROUTINES_XAMAX_H_
+
+#include <vector>
+#include <string>
+
+#ifdef CLBLAST_REF_CLBLAS
+ #include "wrapper_clblas.h"
+#endif
+#ifdef CLBLAST_REF_CBLAS
+ #include "wrapper_cblas.h"
+#endif
+
+namespace clblast {
+// =================================================================================================
+
+// See comment at top of file for a description of the class
+template <typename T>
+class TestXamax {
+ public:
+
+ // The BLAS level: 1, 2, or 3
+ static size_t BLASLevel() { return 1; }
+
+ // The list of arguments relevant for this routine
+ static std::vector<std::string> GetOptions() {
+ return {kArgN,
+ kArgXInc,
+ kArgXOffset, kArgImaxOffset};
+ }
+
+ // Describes how to obtain the sizes of the buffers
+ static size_t GetSizeX(const Arguments<T> &args) {
+ return args.n * args.x_inc + args.x_offset;
+ }
+ static size_t GetSizeImax(const Arguments<T> &args) {
+ return 1 + args.imax_offset;
+ }
+
+ // Describes how to set the sizes of all the buffers
+ static void SetSizes(Arguments<T> &args) {
+ args.x_size = GetSizeX(args);
+ args.scalar_size = GetSizeImax(args);
+ }
+
+ // Describes what the default values of the leading dimensions of the matrices are
+ static size_t DefaultLDA(const Arguments<T> &) { return 1; } // N/A for this routine
+ static size_t DefaultLDB(const Arguments<T> &) { return 1; } // N/A for this routine
+ static size_t DefaultLDC(const Arguments<T> &) { return 1; } // N/A for this routine
+
+ // Describes which transpose options are relevant for this routine
+ using Transposes = std::vector<Transpose>;
+ static Transposes GetATransposes(const Transposes &) { return {}; } // N/A for this routine
+ static Transposes GetBTransposes(const Transposes &) { return {}; } // N/A for this routine
+
+ // Describes how to run the CLBlast routine
+ static StatusCode RunRoutine(const Arguments<T> &args, Buffers<T> &buffers, Queue &queue) {
+ auto queue_plain = queue();
+ auto event = cl_event{};
+ auto status = Amax<T>(args.n,
+ buffers.scalar(), args.imax_offset,
+ buffers.x_vec(), args.x_offset, args.x_inc,
+ &queue_plain, &event);
+ clWaitForEvents(1, &event);
+ return status;
+ }
+
+ // Describes how to run the clBLAS routine (for correctness/performance comparison)
+ #ifdef CLBLAST_REF_CLBLAS
+ static StatusCode RunReference1(const Arguments<T> &args, Buffers<T> &buffers, Queue &queue) {
+ auto queue_plain = queue();
+ auto event = cl_event{};
+ auto status = clblasXamax<T>(args.n,
+ buffers.scalar(), args.imax_offset,
+ buffers.x_vec(), args.x_offset, args.x_inc,
+ 1, &queue_plain, 0, nullptr, &event);
+ clWaitForEvents(1, &event);
+ return static_cast<StatusCode>(status);
+ }
+ #endif
+
+ // Describes how to run the CPU BLAS routine (for correctness/performance comparison)
+ #ifdef CLBLAST_REF_CBLAS
+ static StatusCode RunReference2(const Arguments<T> &args, Buffers<T> &buffers, Queue &queue) {
+ std::vector<T> scalar_cpu(args.scalar_size, static_cast<T>(0));
+ std::vector<T> x_vec_cpu(args.x_size, static_cast<T>(0));
+ buffers.scalar.Read(queue, args.scalar_size, scalar_cpu);
+ buffers.x_vec.Read(queue, args.x_size, x_vec_cpu);
+ cblasXamax(args.n,
+ scalar_cpu, args.imax_offset,
+ x_vec_cpu, args.x_offset, args.x_inc);
+ buffers.scalar.Write(queue, args.scalar_size, scalar_cpu);
+ return StatusCode::kSuccess;
+ }
+ #endif
+
+ // Describes how to download the results of the computation (more importantly: which buffer)
+ static std::vector<T> DownloadResult(const Arguments<T> &args, Buffers<T> &buffers, Queue &queue) {
+ std::vector<T> result(args.scalar_size, static_cast<T>(0));
+ buffers.scalar.Read(queue, args.scalar_size, result);
+ return result;
+ }
+
+ // Describes how to compute the indices of the result buffer
+ static size_t ResultID1(const Arguments<T> &) { return 1; } // N/A for this routine
+ static size_t ResultID2(const Arguments<T> &) { return 1; } // N/A for this routine
+ static size_t GetResultIndex(const Arguments<T> &args, const size_t, const size_t) {
+ return args.imax_offset;
+ }
+
+ // Describes how to compute performance metrics
+ static size_t GetFlops(const Arguments<T> &args) {
+ return args.n;
+ }
+ static size_t GetBytes(const Arguments<T> &args) {
+ return ((args.n) + 1) * sizeof(T);
+ }
+};
+
+// =================================================================================================
+} // namespace clblast
+
+// CLBLAST_TEST_ROUTINES_XAMAX_H_
+#endif
diff --git a/test/wrapper_clblas.h b/test/wrapper_clblas.h
index 955dc3ad..a44466c6 100644
--- a/test/wrapper_clblas.h
+++ b/test/wrapper_clblas.h
@@ -641,7 +641,7 @@ clblasStatus clblasXamax<float>(const size_t n,
cl_uint num_wait_events, const cl_event *wait_events, cl_event *events) {
auto queue = Queue(queues[0]);
auto context = queue.GetContext();
- auto scratch_buffer = Buffer<float>(context, n);
+ auto scratch_buffer = Buffer<float>(context, 2*n);
return clblasiSamax(n,
imax_buffer, imax_offset,
x_buffer, x_offset, static_cast<int>(x_inc),
@@ -656,7 +656,7 @@ clblasStatus clblasXamax<double>(const size_t n,
cl_uint num_wait_events, const cl_event *wait_events, cl_event *events) {
auto queue = Queue(queues[0]);
auto context = queue.GetContext();
- auto scratch_buffer = Buffer<double>(context, n);
+ auto scratch_buffer = Buffer<double>(context, 2*n);
return clblasiDamax(n,
imax_buffer, imax_offset,
x_buffer, x_offset, static_cast<int>(x_inc),
@@ -671,7 +671,7 @@ clblasStatus clblasXamax<float2>(const size_t n,
cl_uint num_wait_events, const cl_event *wait_events, cl_event *events) {
auto queue = Queue(queues[0]);
auto context = queue.GetContext();
- auto scratch_buffer = Buffer<float2>(context, n);
+ auto scratch_buffer = Buffer<float2>(context, 2*n);
return clblasiCamax(n,
imax_buffer, imax_offset,
x_buffer, x_offset, static_cast<int>(x_inc),
@@ -686,7 +686,7 @@ clblasStatus clblasXamax<double2>(const size_t n,
cl_uint num_wait_events, const cl_event *wait_events, cl_event *events) {
auto queue = Queue(queues[0]);
auto context = queue.GetContext();
- auto scratch_buffer = Buffer<double2>(context, n);
+ auto scratch_buffer = Buffer<double2>(context, 2*n);
return clblasiZamax(n,
imax_buffer, imax_offset,
x_buffer, x_offset, static_cast<int>(x_inc),