summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2016-06-06 13:40:52 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2016-06-06 13:40:52 +0200
commit7a7873d5527e7819249f80ba9abceb9d2d9c41cb (patch)
tree25fbf4a1da556bdb73b69ec2a79eb47791afc887
parentc1895ea459d8084b49ced14eb08b77e551c5ba9c (diff)
Fixed the RPATH settings for linking on OS X
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 95b0679c..5cad6d45 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,10 +30,7 @@ option(TESTS "Enable compilation of the correctness tests" OFF)
# ==================================================================================================
# RPATH settings
-set(CMAKE_SKIP_BUILD_RPATH false) # Use, i.e. don't skip the full RPATH for the build tree
-set(CMAKE_BUILD_WITH_INSTALL_RPATH false) # When building, don't use the install RPATH already
-set(CMAKE_INSTALL_RPATH "") # The RPATH to be used when installing
-set(CMAKE_INSTALL_RPATH_USE_LINK_PATH false) # Don't add the automatically determined parts
+set(CMAKE_MACOSX_RPATH 1)
# ==================================================================================================