summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2016-05-31 20:53:55 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2016-05-31 20:53:55 +0200
commit983df6a8b47a41a9575a3b857ab16afdd18908d0 (patch)
treebad5a9e0c849e1e78ec7a6f93f78acb720fb3853
parentf6b2cd95793f12a5d8e146fd99a7cdc4e76cb4a9 (diff)
Made use of CMake's built-in unit testing, allowing all tests to be run using 'make test'
-rw-r--r--CHANGELOG3
-rw-r--r--CMakeLists.txt2
2 files changed, 4 insertions, 1 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 4d4773c7..48963af4 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,9 +1,10 @@
Development version (next release)
+- Added support for half-precision floating-point (fp16) in the library
- Made it possible to compile the performance tests (clients) separately from the correctness tests
- Made a reference BLAS and head-to-head performance comparison optional in the clients
- Increased the verbosity of the "-verbose" option in the correctness tests
-- Added support for half-precision floating-point (fp16) in the library
+- Various minor fixes and enhancements
- Added half-precision routines:
* Level-1: HSWAP/HSCAL/HCOPY/HAXPY/HDOT/HNRM2/HASUM/HSUM/iHAMAX/iHMAX/iHMIN
* Level-2: HGEMV/HGBMV/HHEMV/HHBMV/HHPMV/HSYMV/HSBMV/HSPMV/HTRMV/HTBMV/HTPMV/HGER/HSYR/HSPR/HSYR2/HSPR2
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 641e7966..95b0679c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -294,6 +294,7 @@ endif()
# Section for the correctness tests. Note that these tests require the presence of clBLAS and/or a
# CPU BLAS library to act as a reference.
if(TESTS)
+ enable_testing()
# Creates the common correctness-tests objects (requires CMake 2.8.8)
add_library(test_correctness_common OBJECT
@@ -315,6 +316,7 @@ if(TESTS)
foreach(ROUTINE ${ROUTINES})
target_link_libraries(clblast_test_${ROUTINE} clblast ${REF_LIBRARIES} ${OPENCL_LIBRARIES})
install(TARGETS clblast_test_${ROUTINE} DESTINATION bin)
+ add_test(clblast_test_${ROUTINE} clblast_test_${ROUTINE})
endforeach()
# Adds 'alltests' target: runs all tests