summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Lokhmotov <anton@dividiti.com>2016-09-26 21:04:28 +0000
committerAnton Lokhmotov <anton@dividiti.com>2016-09-26 21:04:28 +0000
commitc484bb26b6b3d9290fd4833faf4f4d9357614903 (patch)
tree76d5a5ac8d2e82e00a6c44937bede50f6d62daab
parentc20a5bb7caa745452e25c0bd6c7d8f59278aa374 (diff)
Use cross-platform thread lib idiom instead of *nix-specific pthread.
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e86ca43f..21e38f1d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -272,8 +272,9 @@ if(CLIENTS OR TESTS)
set(REF_INCLUDES )
set(REF_LIBRARIES )
if(CLBLAS_FOUND)
+ find_package(Threads)
+ set(REF_LIBRARIES ${REF_LIBRARIES} ${CLBLAS_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
set(REF_INCLUDES ${REF_INCLUDES} ${CLBLAS_INCLUDE_DIRS})
- set(REF_LIBRARIES ${REF_LIBRARIES} ${CLBLAS_LIBRARIES} pthread)
if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
add_definitions(" /DCLBLAST_REF_CLBLAS")
else()