summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2022-09-27 22:45:49 +0200
committerGitHub <noreply@github.com>2022-09-27 22:45:49 +0200
commitd55840e16cda7cb8bb8b8c81e5294833c81913e8 (patch)
tree04a929951ed0ad37523c78c6bdc60f64d6b2f1e7
parent38fa34b43243722330e2ae1caffa344745d612c8 (diff)
parente0806350195375385f4b4aab27ec9f2b54fc0fbe (diff)
Merge pull request #442 from CNugteren/update_version_to_1_5_3
Update to version 1.5.3
-rw-r--r--.appveyor.yml8
-rw-r--r--.gitignore1
-rw-r--r--.travis.yml2
-rw-r--r--CHANGELOG3
-rw-r--r--CMakeLists.txt6
-rw-r--r--include/clblast.h4
-rw-r--r--include/clblast_c.h4
-rw-r--r--samples/dtrsm.cpp6
-rw-r--r--samples/sgemm.cpp6
-rw-r--r--samples/sgemm_batched.cpp6
-rw-r--r--samples/tuning_api.cpp6
-rw-r--r--src/pyclblast/README.md2
-rw-r--r--src/pyclblast/setup.py2
13 files changed, 32 insertions, 24 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 0fc3ca55..a27b3070 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -1,7 +1,6 @@
environment:
global:
CLBLAST_BUILD: "C:\\clblast\\build"
- OPENCL_REGISTRY: "https://www.khronos.org/registry/cl"
OPENCL_ROOT: "C:\\dependencies\\opencl"
platform:
@@ -18,7 +17,6 @@ init:
install:
- ps: mkdir $env:OPENCL_ROOT
- ps: pushd $env:OPENCL_ROOT
- - ps: $opencl_registry = $env:OPENCL_REGISTRY
# This downloads the source to the Khronos ICD library
- git clone https://github.com/KhronosGroup/OpenCL-ICD-Loader.git
- ps: pushd OpenCL-ICD-Loader
@@ -29,7 +27,7 @@ install:
# The cmake build files expect a directory called inc
- ps: mkdir inc/CL
- git clone https://github.com/KhronosGroup/OpenCL-Headers.git inc/CL
- - ps: wget $opencl_registry/api/2.1/cl.hpp -OutFile inc/CL/cl.hpp
+ - ps: wget https://raw.githubusercontent.com/KhronosGroup/OpenCL-CLHPP/main/include/CL/opencl.hpp -OutFile inc/CL/cl.hpp
# Switch to OpenCL 2.1 headers
- ps: pushd inc/CL
- git checkout bf0f43b # OpenCL 2.1
@@ -57,8 +55,8 @@ build_script:
after_build:
- ps: pushd $env:CLBLAST_BUILD
- - 7z a CLBlast-1.5.2-Windows-x64.zip .\install_dir\*
- - ps: mv CLBlast-1.5.2-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
+ - 7z a CLBlast-1.5.3-Windows-x64.zip .\install_dir\*
+ - ps: mv CLBlast-1.5.3-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
artifacts:
- path: '*.zip'
diff --git a/.gitignore b/.gitignore
index b0f39c40..ab80cec1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,5 +5,6 @@ stash
database.json
database_best.json
cl.hpp
+opencl.hpp
src/pyclblast/dist
*.egg-info
diff --git a/.travis.yml b/.travis.yml
index f937222d..dbdae42e 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -21,7 +21,7 @@ matrix:
env:
global:
- - CLBLAST_VERSION=1.5.2
+ - CLBLAST_VERSION=1.5.3
- CLBLAST_ROOT=${TRAVIS_BUILD_DIR}/bin/clblast
- CLBLAST_INSTALL=${TRAVIS_BUILD_DIR}/bin/CLBlast-${CLBLAST_VERSION}
- CLBLAST_TAR=CLBlast-${CLBLAST_VERSION}-${TRAVIS_OS_NAME}-x64.tar.gz
diff --git a/CHANGELOG b/CHANGELOG
index 8ae1874e..f815d316 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,7 +1,8 @@
-Development version (next version)
+Version 1.5.3
- Fix a correctness issue with DGEMM on SM 7.5 Turing GPUs
- Various minor fixes and enhancements
- Added tuned parameters for various devices (see doc/tuning.md)
+- Update cl.hpp to the new opencl.hpp header in the samples
- Changed the complex sum routine to return the complex sum instead of the absolute complex sum.
Version 1.5.2
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 84966bc9..cde7ace0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,7 +22,7 @@ endif()
project("clblast" C CXX)
set(clblast_VERSION_MAJOR 1)
set(clblast_VERSION_MINOR 5)
-set(clblast_VERSION_PATCH 2)
+set(clblast_VERSION_PATCH 3)
set(clblast_VERSION "${clblast_VERSION_MAJOR}.${clblast_VERSION_MINOR}.${clblast_VERSION_PATCH}")
set(clblast_SOVERSION ${clblast_VERSION_MAJOR})
@@ -374,9 +374,9 @@ endif()
# This section contains all the code related to the examples
if(SAMPLES)
- # Downloads the cl.hpp file from Khronos
+ # Downloads the opencl.hpp file from Khronos
if(OPENCL)
- file(DOWNLOAD https://www.khronos.org/registry/OpenCL/api/2.1/cl.hpp ${clblast_SOURCE_DIR}/samples/cl.hpp)
+ file(DOWNLOAD https://raw.githubusercontent.com/KhronosGroup/OpenCL-CLHPP/main/include/CL/opencl.hpp ${clblast_SOURCE_DIR}/samples/opencl.hpp)
endif()
# Adds sample programs (C++)
diff --git a/include/clblast.h b/include/clblast.h
index c11e4ab0..99364ec6 100644
--- a/include/clblast.h
+++ b/include/clblast.h
@@ -39,10 +39,10 @@
#define PUBLIC_API
#endif
-// Version numbering (v1.5.1)
+// Version numbering (v1.5.3)
#define CLBLAST_VERSION_MAJOR 1
#define CLBLAST_VERSION_MINOR 5
-#define CLBLAST_VERSION_PATCH 1
+#define CLBLAST_VERSION_PATCH 3
namespace clblast {
// =================================================================================================
diff --git a/include/clblast_c.h b/include/clblast_c.h
index 9c2820b2..07f1fd0c 100644
--- a/include/clblast_c.h
+++ b/include/clblast_c.h
@@ -34,10 +34,10 @@
#define PUBLIC_API
#endif
-// Version numbering (v1.5.1)
+// Version numbering (v1.5.3)
#define CLBLAST_VERSION_MAJOR 1
#define CLBLAST_VERSION_MINOR 5
-#define CLBLAST_VERSION_PATCH 1
+#define CLBLAST_VERSION_PATCH 3
// The C interface
#ifdef __cplusplus
diff --git a/samples/dtrsm.cpp b/samples/dtrsm.cpp
index 6d37dad7..c558d1f5 100644
--- a/samples/dtrsm.cpp
+++ b/samples/dtrsm.cpp
@@ -23,8 +23,10 @@
#define CL_USE_DEPRECATED_OPENCL_1_2_APIS // to disable deprecation warnings
// Includes the C++ OpenCL API. If not yet available, it can be found here:
-// https://www.khronos.org/registry/cl/api/1.1/cl.hpp
-#include "cl.hpp"
+// https://raw.githubusercontent.com/KhronosGroup/OpenCL-CLHPP/main/include/CL/opencl.hpp
+#define CL_HPP_TARGET_OPENCL_VERSION 210
+#define CL_TARGET_OPENCL_VERSION 210
+#include "opencl.hpp"
// Includes the CLBlast library
#include <clblast.h>
diff --git a/samples/sgemm.cpp b/samples/sgemm.cpp
index ab7858e1..534ffa78 100644
--- a/samples/sgemm.cpp
+++ b/samples/sgemm.cpp
@@ -24,8 +24,10 @@
#define CL_USE_DEPRECATED_OPENCL_1_2_APIS // to disable deprecation warnings
// Includes the C++ OpenCL API. If not yet available, it can be found here:
-// https://www.khronos.org/registry/cl/api/1.1/cl.hpp
-#include "cl.hpp"
+// https://raw.githubusercontent.com/KhronosGroup/OpenCL-CLHPP/main/include/CL/opencl.hpp
+#define CL_HPP_TARGET_OPENCL_VERSION 210
+#define CL_TARGET_OPENCL_VERSION 210
+#include "opencl.hpp"
// Includes the CLBlast library
#include <clblast.h>
diff --git a/samples/sgemm_batched.cpp b/samples/sgemm_batched.cpp
index 32c465c7..a839d305 100644
--- a/samples/sgemm_batched.cpp
+++ b/samples/sgemm_batched.cpp
@@ -24,8 +24,10 @@
#define CL_USE_DEPRECATED_OPENCL_1_2_APIS // to disable deprecation warnings
// Includes the C++ OpenCL API. If not yet available, it can be found here:
-// https://www.khronos.org/registry/cl/api/1.1/cl.hpp
-#include "cl.hpp"
+// https://raw.githubusercontent.com/KhronosGroup/OpenCL-CLHPP/main/include/CL/opencl.hpp
+#define CL_HPP_TARGET_OPENCL_VERSION 210
+#define CL_TARGET_OPENCL_VERSION 210
+#include "opencl.hpp"
// Includes the CLBlast library
#include <clblast.h>
diff --git a/samples/tuning_api.cpp b/samples/tuning_api.cpp
index f92b6909..7d7294ad 100644
--- a/samples/tuning_api.cpp
+++ b/samples/tuning_api.cpp
@@ -20,8 +20,10 @@
#define CL_USE_DEPRECATED_OPENCL_1_2_APIS // to disable deprecation warnings
// Includes the C++ OpenCL API. If not yet available, it can be found here:
-// https://www.khronos.org/registry/cl/api/1.1/cl.hpp
-#include "cl.hpp"
+// https://raw.githubusercontent.com/KhronosGroup/OpenCL-CLHPP/main/include/CL/opencl.hpp
+#define CL_HPP_TARGET_OPENCL_VERSION 210
+#define CL_TARGET_OPENCL_VERSION 210
+#include "opencl.hpp"
// Includes the CLBlast library
#include <clblast.h>
diff --git a/src/pyclblast/README.md b/src/pyclblast/README.md
index 2ba57374..c6acc7b0 100644
--- a/src/pyclblast/README.md
+++ b/src/pyclblast/README.md
@@ -54,5 +54,5 @@ How to release a new version on PyPi
Following [the guide](https://packaging.python.org/tutorials/packaging-projects/), in essence doing (after changing the version number in `setup.py`):
python3 setup.py sdist bdist_wheel
- python3 -m twine upload --repository pypi dist/pyclblast-1.3.1.tar.gz
+ python3 -m twine upload --repository pypi dist/pyclblast-1.3.2.tar.gz
# use '__token__' as username and supply the token from your PyPi account
diff --git a/src/pyclblast/setup.py b/src/pyclblast/setup.py
index 334df8de..c2a716b1 100644
--- a/src/pyclblast/setup.py
+++ b/src/pyclblast/setup.py
@@ -30,7 +30,7 @@ ext_modules.append(
setup(
name="pyclblast",
- version="1.3.1",
+ version="1.3.2",
author="Cedric Nugteren",
author_email="web@cedricnugteren.nl",
url="https://github.com/CNugteren/CLBlast/blob/master/src/pyclblast",