summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2016-10-22 16:38:42 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2016-10-22 16:38:42 +0200
commitde0420dffa0dc1bcdad308e24224ad6378418d67 (patch)
tree5480606202030184868717ef4f7b073d4c019008
parentc925fe463f2caee973426070e76accf34e296e76 (diff)
Minor clean-up of the CMakeLists file
-rw-r--r--CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 04388c6e..f79c9121 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,9 +69,7 @@ endif()
if(MSVC)
if(BUILD_SHARED_LIBS)
add_definitions(" /DCLBLAST_DLL")
- else(BUILD_SHARED_LIBS)
- add_definitions(" /DCLBLAST_STATIC")
- endif(BUILD_SHARED_LIBS)
+ endif()
endif(MSVC)
# C++ compiler settings
@@ -192,7 +190,7 @@ if(BUILD_SHARED_LIBS)
add_library(clblast SHARED ${SOURCES})
else(BUILD_SHARED_LIBS)
add_library(clblast STATIC ${SOURCES})
-endif(BUILD_SHARED_LIBS)
+endif()
target_link_libraries(clblast ${OPENCL_LIBRARIES})
@@ -207,7 +205,7 @@ target_include_directories(clblast PUBLIC
if(MSVC)
if(BUILD_SHARED_LIBS)
target_compile_definitions(clblast PRIVATE COMPILING_DLL=1) # requires at least CMake 2.8.11
- endif(BUILD_SHARED_LIBS)
+ endif()
endif()
# Installs the library