summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2021-01-21 20:43:22 +0100
committerCedric Nugteren <web@cedricnugteren.nl>2021-01-21 20:49:31 +0100
commit07837a5c2d8ce7290b1c950a32ef0b887c33e02f (patch)
tree233a080a41f88931e372091f36e29708cacab12d
parenta5ef06ec57a1c05aeb4564020022002c2ac53bb5 (diff)
Update pyclblast package version number
-rw-r--r--src/pyclblast/README.md11
-rw-r--r--src/pyclblast/setup.py2
2 files changed, 12 insertions, 1 deletions
diff --git a/src/pyclblast/README.md b/src/pyclblast/README.md
index a6a55907..2ba57374 100644
--- a/src/pyclblast/README.md
+++ b/src/pyclblast/README.md
@@ -39,9 +39,20 @@ And then compile the library from this location using the `setup.py` file:
python setup.py install
+
Testing PyCLBlast
-------------
The main exhaustive tests are the main CLBlast test binaries. Apart from that, you can also run the PyCLBlast smoke tests from the `test` subfolder, e.g. as follows:
python -m unittest discover
+
+
+How to release a new version on PyPi
+-------------
+
+Following [the guide](https://packaging.python.org/tutorials/packaging-projects/), in essence doing (after changing the version number in `setup.py`):
+
+ python3 setup.py sdist bdist_wheel
+ python3 -m twine upload --repository pypi dist/pyclblast-1.3.1.tar.gz
+ # use '__token__' as username and supply the token from your PyPi account
diff --git a/src/pyclblast/setup.py b/src/pyclblast/setup.py
index bcc966ed..3da1e454 100644
--- a/src/pyclblast/setup.py
+++ b/src/pyclblast/setup.py
@@ -22,7 +22,7 @@ ext_modules.append(
setup(
name="pyclblast",
- version="1.3.0",
+ version="1.3.1",
author="Cedric Nugteren",
author_email="web@cedricnugteren.nl",
url="https://github.com/CNugteren/CLBlast/blob/master/src/pyclblast",