summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2017-07-30 18:34:39 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2017-07-30 18:34:39 +0200
commit6ceb9b71526e3a51b71b79e26e05cb14b32472af (patch)
tree9810e3c199b437050bf7feaf993bfe08b4a75fa1
parente6f938e0e9fd11003bd4ed7a6993951b064a8dfa (diff)
Fixes to AppVeyor and Travis scripts
-rw-r--r--.appveyor.yml5
-rw-r--r--.travis.yml7
-rw-r--r--CMakeLists.txt6
3 files changed, 10 insertions, 8 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index e5dff100..adb1860b 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -3,7 +3,6 @@ environment:
CLBLAST_BUILD: "C:\\clblast\\build"
OPENCL_REGISTRY: "https://www.khronos.org/registry/cl"
OPENCL_ROOT: "C:\\dependencies\\opencl"
- CLBLAST_VERSION: "1.0.0"
platform:
- x64
@@ -59,8 +58,8 @@ build_script:
after_build:
- ps: pushd $env:CLBLAST_BUILD
- - 7z a CLBlast-$env:CLBLAST_BUILD-Windows-x64.zip .\install_dir\*
- - ps: mv CLBlast-$env:CLBLAST_BUILD-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
+ - 7z a CLBlast-1.0.0-Windows-x64.zip .\install_dir\*
+ - ps: mv CLBlast-1.0.0-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
artifacts:
- path: '*.zip'
diff --git a/.travis.yml b/.travis.yml
index 0693d74f..8d7c798c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -43,9 +43,10 @@ script:
after_success:
- pushd ${TRAVIS_BUILD_DIR}/bin
- - rm ${CLBLAST_INSTALL}/clblast_client_*
- - rm ${CLBLAST_INSTALL}/clblast_test_*
- - tar -cvf ${CLBLAST_TAR} ${CLBLAST_INSTALL}
+ - rm ${CLBLAST_INSTALL}/bin/clblast_client_*
+ - rm ${CLBLAST_INSTALL}/bin/clblast_test_*
+ - tar -cvf ${CLBLAST_TAR} CLBlast-${CLBLAST_VERSION}
+ - cp ${CLBLAST_TAR} ${TRAVIS_BUILD_DIR}
branches:
only:
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 595c6b89..049662b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,8 +101,10 @@ else()
set(FLAGS "${FLAGS} -Wno-missing-prototypes -Wno-float-equal -Wno-switch-enum -Wno-switch")
set(FLAGS "${FLAGS} -Wno-exit-time-destructors -Wno-global-constructors -Wno-missing-noreturn")
set(FLAGS "${FLAGS} -Wno-deprecated-declarations")
- if(CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 3.9.0)
- set(FLAGS "${FLAGS} -Wno-undefined-var-template")
+ if(NOT CMAKE_CXX_COMPILER_ID MATCHES AppleClang)
+ if(CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 3.9.0)
+ set(FLAGS "${FLAGS} -Wno-undefined-var-template")
+ endif()
endif()
endif()
endif()