summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2016-09-27 08:53:08 +0200
committerGitHub <noreply@github.com>2016-09-27 08:53:08 +0200
commita2bfae3c4618956a85379f09ba03beeb583c098d (patch)
tree90db3ba283c6a44ce1f88e123f779264b892ac41
parent8a5ce050227538abff2179ed70ce0e958e2ec0d1 (diff)
parentc484bb26b6b3d9290fd4833faf4f4d9357614903 (diff)
Merge pull request #103 from dividiti/link_clblas_with_pthread
Link clBLAS together with pthread
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 727ba42f..21e38f1d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -272,8 +272,9 @@ if(CLIENTS OR TESTS)
set(REF_INCLUDES )
set(REF_LIBRARIES )
if(CLBLAS_FOUND)
+ find_package(Threads)
+ set(REF_LIBRARIES ${REF_LIBRARIES} ${CLBLAS_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
set(REF_INCLUDES ${REF_INCLUDES} ${CLBLAS_INCLUDE_DIRS})
- set(REF_LIBRARIES ${REF_LIBRARIES} ${CLBLAS_LIBRARIES})
if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
add_definitions(" /DCLBLAST_REF_CLBLAS")
else()