summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2022-09-22 22:18:58 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2022-09-22 22:18:58 +0200
commitf7db4c5d45db1ebbc9cc824cbda652b88362574c (patch)
tree2dd9263f6f974cfb029e38f166ec94dd9979f125
parent521eee4bbfdaf9c15bbae97e65fa8f002453a384 (diff)
Replace the broken khronos registry link for cl.hpp with a new github link for opencl.hpp
-rw-r--r--.appveyor.yml4
-rw-r--r--CHANGELOG1
-rw-r--r--CMakeLists.txt2
-rw-r--r--samples/dtrsm.cpp4
-rw-r--r--samples/sgemm.cpp4
-rw-r--r--samples/sgemm_batched.cpp4
-rw-r--r--samples/tuning_api.cpp4
7 files changed, 11 insertions, 12 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 41543866..a27b3070 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -1,7 +1,6 @@
environment:
global:
CLBLAST_BUILD: "C:\\clblast\\build"
- OPENCL_REGISTRY: "https://www.khronos.org/registry/cl"
OPENCL_ROOT: "C:\\dependencies\\opencl"
platform:
@@ -18,7 +17,6 @@ init:
install:
- ps: mkdir $env:OPENCL_ROOT
- ps: pushd $env:OPENCL_ROOT
- - ps: $opencl_registry = $env:OPENCL_REGISTRY
# This downloads the source to the Khronos ICD library
- git clone https://github.com/KhronosGroup/OpenCL-ICD-Loader.git
- ps: pushd OpenCL-ICD-Loader
@@ -29,7 +27,7 @@ install:
# The cmake build files expect a directory called inc
- ps: mkdir inc/CL
- git clone https://github.com/KhronosGroup/OpenCL-Headers.git inc/CL
- - ps: wget $opencl_registry/api/2.1/cl.hpp -OutFile inc/CL/cl.hpp
+ - ps: wget https://raw.githubusercontent.com/KhronosGroup/OpenCL-CLHPP/main/include/CL/opencl.hpp -OutFile inc/CL/cl.hpp
# Switch to OpenCL 2.1 headers
- ps: pushd inc/CL
- git checkout bf0f43b # OpenCL 2.1
diff --git a/CHANGELOG b/CHANGELOG
index 800aca3d..f815d316 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -2,6 +2,7 @@ Version 1.5.3
- Fix a correctness issue with DGEMM on SM 7.5 Turing GPUs
- Various minor fixes and enhancements
- Added tuned parameters for various devices (see doc/tuning.md)
+- Update cl.hpp to the new opencl.hpp header in the samples
- Changed the complex sum routine to return the complex sum instead of the absolute complex sum.
Version 1.5.2
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a0cf163..19bd3218 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -376,7 +376,7 @@ if(SAMPLES)
# Downloads the cl.hpp file from Khronos
if(OPENCL)
- file(DOWNLOAD https://www.khronos.org/registry/OpenCL/api/2.1/cl.hpp ${clblast_SOURCE_DIR}/samples/cl.hpp)
+ file(DOWNLOAD https://raw.githubusercontent.com/KhronosGroup/OpenCL-CLHPP/main/include/CL/opencl.hpp ${clblast_SOURCE_DIR}/samples/cl.hpp)
endif()
# Adds sample programs (C++)
diff --git a/samples/dtrsm.cpp b/samples/dtrsm.cpp
index 6d37dad7..979c01d9 100644
--- a/samples/dtrsm.cpp
+++ b/samples/dtrsm.cpp
@@ -23,8 +23,8 @@
#define CL_USE_DEPRECATED_OPENCL_1_2_APIS // to disable deprecation warnings
// Includes the C++ OpenCL API. If not yet available, it can be found here:
-// https://www.khronos.org/registry/cl/api/1.1/cl.hpp
-#include "cl.hpp"
+// https://raw.githubusercontent.com/KhronosGroup/OpenCL-CLHPP/main/include/CL/opencl.hpp
+#include "opencl.hpp"
// Includes the CLBlast library
#include <clblast.h>
diff --git a/samples/sgemm.cpp b/samples/sgemm.cpp
index ab7858e1..fce2af43 100644
--- a/samples/sgemm.cpp
+++ b/samples/sgemm.cpp
@@ -24,8 +24,8 @@
#define CL_USE_DEPRECATED_OPENCL_1_2_APIS // to disable deprecation warnings
// Includes the C++ OpenCL API. If not yet available, it can be found here:
-// https://www.khronos.org/registry/cl/api/1.1/cl.hpp
-#include "cl.hpp"
+// https://raw.githubusercontent.com/KhronosGroup/OpenCL-CLHPP/main/include/CL/opencl.hpp
+#include "opencl.hpp"
// Includes the CLBlast library
#include <clblast.h>
diff --git a/samples/sgemm_batched.cpp b/samples/sgemm_batched.cpp
index 32c465c7..a986eec7 100644
--- a/samples/sgemm_batched.cpp
+++ b/samples/sgemm_batched.cpp
@@ -24,8 +24,8 @@
#define CL_USE_DEPRECATED_OPENCL_1_2_APIS // to disable deprecation warnings
// Includes the C++ OpenCL API. If not yet available, it can be found here:
-// https://www.khronos.org/registry/cl/api/1.1/cl.hpp
-#include "cl.hpp"
+// https://raw.githubusercontent.com/KhronosGroup/OpenCL-CLHPP/main/include/CL/opencl.hpp
+#include "opencl.hpp"
// Includes the CLBlast library
#include <clblast.h>
diff --git a/samples/tuning_api.cpp b/samples/tuning_api.cpp
index f92b6909..ea75c7f9 100644
--- a/samples/tuning_api.cpp
+++ b/samples/tuning_api.cpp
@@ -20,8 +20,8 @@
#define CL_USE_DEPRECATED_OPENCL_1_2_APIS // to disable deprecation warnings
// Includes the C++ OpenCL API. If not yet available, it can be found here:
-// https://www.khronos.org/registry/cl/api/1.1/cl.hpp
-#include "cl.hpp"
+// https://raw.githubusercontent.com/KhronosGroup/OpenCL-CLHPP/main/include/CL/opencl.hpp
+#include "opencl.hpp"
// Includes the CLBlast library
#include <clblast.h>