summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2017-11-08 21:30:06 +0100
committerCedric Nugteren <web@cedricnugteren.nl>2017-11-08 21:30:06 +0100
commit5d5e3f93bca53ac5069a3de8ede56b89a536bccc (patch)
tree2e1e77b6f308f82c462f570d76f328e0a44162ba
parentd24138808b42368a4dfe67fc9bdef546b6c358e8 (diff)
Updated to CLBlast version 1.2.0
-rw-r--r--.appveyor.yml4
-rw-r--r--.travis.yml2
-rw-r--r--CHANGELOG4
-rw-r--r--CMakeLists.txt2
-rw-r--r--README.md3
5 files changed, 8 insertions, 7 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 0aefffb7..9858e1fc 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -58,8 +58,8 @@ build_script:
after_build:
- ps: pushd $env:CLBLAST_BUILD
- - 7z a CLBlast-1.1.0-Windows-x64.zip .\install_dir\*
- - ps: mv CLBlast-1.1.0-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
+ - 7z a CLBlast-1.2.0-Windows-x64.zip .\install_dir\*
+ - ps: mv CLBlast-1.2.0-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
artifacts:
- path: '*.zip'
diff --git a/.travis.yml b/.travis.yml
index 0d18fbf4..4b17b8a0 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -21,7 +21,7 @@ matrix:
env:
global:
- - CLBLAST_VERSION=1.1.0
+ - CLBLAST_VERSION=1.2.0
- CLBLAST_ROOT=${TRAVIS_BUILD_DIR}/bin/clblast
- CLBLAST_INSTALL=${TRAVIS_BUILD_DIR}/bin/CLBlast-${CLBLAST_VERSION}
- CLBLAST_TAR=CLBlast-${CLBLAST_VERSION}-${TRAVIS_OS_NAME}-x64.tar.gz
diff --git a/CHANGELOG b/CHANGELOG
index 02bee585..f30944a5 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,5 +1,5 @@
-Development (next version)
+Version 1.2.0
- Fixed a bug in the TRSM/TRSV routines due to missing synchronisations after GEMM/GEMV calls
- Fixed a bug in TRSM when using the a-offset argument
- Added a CUDA API to CLBlast:
@@ -27,7 +27,7 @@ Version 1.1.0
* SIM2COL/DIM2COL/CIM2COL/ZIM2COL/HIM2COL (im2col transform as used to express convolution as GEMM)
Version 1.0.1
-- Fixed a bug in the direct version of the GEMM kernel)
+- Fixed a bug in the direct version of the GEMM kernel
Version 1.0.0
- Fixed a bug in the TRSM routine for alpha != 1
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a97a4eb0..cada61ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,7 +21,7 @@ endif()
# CMake project details
project("clblast" C CXX)
set(clblast_VERSION_MAJOR 1)
-set(clblast_VERSION_MINOR 1)
+set(clblast_VERSION_MINOR 2)
set(clblast_VERSION_PATCH 0)
# Options and their default values
diff --git a/README.md b/README.md
index 44163e7e..8a92a71a 100644
--- a/README.md
+++ b/README.md
@@ -24,7 +24,7 @@ Use CLBlast instead of clBLAS:
* When you are still running on OpenCL 1.1 hardware.
* When you prefer a C++ API over a C API (C API also available in CLBlast).
* When you value an organized and modern C++ codebase.
-* When you target Intel CPUs and GPUs or embedded devices
+* When you target Intel CPUs and GPUs or embedded devices.
* When you can benefit from the increased performance of half-precision fp16 data-types.
Use CLBlast instead of cuBLAS:
@@ -58,6 +58,7 @@ The pre-requisites for compilation of CLBlast are:
- Intel OpenCL
- Beignet
- Mesa Clover
+ - ARM Mali OpenCL
An example of an out-of-source build using a command-line compiler and make (starting from the root of the CLBlast folder):