summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2021-01-19 21:19:12 +0100
committerCedric Nugteren <web@cedricnugteren.nl>2021-01-19 21:19:12 +0100
commit70016e869881df837402def4904b2888247e02d9 (patch)
treece5bcc39acc97ba92ceb3fd8429d00a40489a8eb
parent0ee39af5edf9c66e8153674dcaccb06aacd7315f (diff)
Updated to version 1.5.2
-rw-r--r--.appveyor.yml4
-rw-r--r--.travis.yml2
-rw-r--r--CHANGELOG8
-rw-r--r--CMakeLists.txt2
4 files changed, 8 insertions, 8 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 8ff37320..0fc3ca55 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -57,8 +57,8 @@ build_script:
after_build:
- ps: pushd $env:CLBLAST_BUILD
- - 7z a CLBlast-1.5.1-Windows-x64.zip .\install_dir\*
- - ps: mv CLBlast-1.5.1-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
+ - 7z a CLBlast-1.5.2-Windows-x64.zip .\install_dir\*
+ - ps: mv CLBlast-1.5.2-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
artifacts:
- path: '*.zip'
diff --git a/.travis.yml b/.travis.yml
index e6d7fd16..f937222d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -21,7 +21,7 @@ matrix:
env:
global:
- - CLBLAST_VERSION=1.5.1
+ - CLBLAST_VERSION=1.5.2
- CLBLAST_ROOT=${TRAVIS_BUILD_DIR}/bin/clblast
- CLBLAST_INSTALL=${TRAVIS_BUILD_DIR}/bin/CLBlast-${CLBLAST_VERSION}
- CLBLAST_TAR=CLBlast-${CLBLAST_VERSION}-${TRAVIS_OS_NAME}-x64.tar.gz
diff --git a/CHANGELOG b/CHANGELOG
index 98d46a27..e3614d80 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,11 +1,11 @@
-Development version (next version)
+Version 1.5.2
- Changed XAMAX/XAMIN to more likely return first rather than last min/max index, updated API docs
-- Fixed a bug in the tuners related to global workgroup size not being a multiple of the local
- Added batched routines to pyclblast
- Added CLBLAST_VERSION_MAJOR/MINOR/PATCH defines in headers to store version numbering
-- Various minor fixes and enhancements
-- Fixed a bug in the caching when using a context with multiple devices
- Several small improvements to the benchmark script (thanks to 'baryluk')
+- Fixed a bug in the caching when using a context with multiple devices
+- Fixed a bug in the tuners related to global workgroup size not being a multiple of the local
+- Various minor fixes and enhancements
- Added tuned parameters for various devices (see doc/tuning.md)
Version 1.5.1
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7b7d45a5..2d280503 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,7 +22,7 @@ endif()
project("clblast" C CXX)
set(clblast_VERSION_MAJOR 1)
set(clblast_VERSION_MINOR 5)
-set(clblast_VERSION_PATCH 1)
+set(clblast_VERSION_PATCH 2)
set(clblast_VERSION "${clblast_VERSION_MAJOR}.${clblast_VERSION_MINOR}.${clblast_VERSION_PATCH}")
set(clblast_SOVERSION ${clblast_VERSION_MAJOR})