summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2018-08-07 22:41:06 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2018-08-07 22:41:06 +0200
commit9d9f09fce9d42247701c16d89ca356cdd3a76b4b (patch)
tree2401badea0664b405e1fd62c0d35395d98eca652
parentfe639455bd1e02c22c459f9e29654f82652e0a97 (diff)
Name change of setting to NETLIB_PERSISTENT_OPENCL
-rw-r--r--CHANGELOG2
-rw-r--r--CMakeLists.txt6
-rw-r--r--src/clblast_netlib_c.cpp2
3 files changed, 5 insertions, 5 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 64889ee6..f2960fde 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,7 +1,7 @@
Development (next version)
- Added support for shuffle instructions for NVIDIA GPUs (thanks to 'tyler-utah')
-- Added an option to compile the Netlib API with static OpenCL device and context (-DNETLIB_STATIC_OPENCL=ON)
+- Added an option to compile the Netlib API with static OpenCL device and context (-DNETLIB_PERSISTENT_OPENCL=ON)
- The tuners now check beforehand on invalid local thread sizes and skip those completely
- Fixed an issue with conjugate transpose not being executed in certain cases for a.o. XOMATCOPY
- Fixed an issue with AMD GPUs and the new GEMMK == 1 kernel
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 806b4b26..fd201021 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,12 +36,12 @@ option(CUBLAS "Enables performance comparison against cuBLAS on NVIDIA GPUs" OFF
# The optional Netlib API for CLBlast
option(NETLIB "Enable compilation of the CBLAS Netlib API" OFF)
-option(NETLIB_STATIC_OPENCL "Makes OpenCL device and context in the CBLAS Netlib API static" OFF)
+option(NETLIB_PERSISTENT_OPENCL "Makes OpenCL device and context in the CBLAS Netlib API static" OFF)
if(NETLIB)
message("-- Building the Netlib API of CLBlast")
- if(NETLIB_STATIC_OPENCL)
+ if(NETLIB_PERSISTENT_OPENCL)
message(" ^^ while using static variables for OpenCL device and context")
- add_definitions(-DNETLIB_STATIC_OPENCL)
+ add_definitions(-DNETLIB_PERSISTENT_OPENCL)
endif()
endif()
diff --git a/src/clblast_netlib_c.cpp b/src/clblast_netlib_c.cpp
index aa1f4006..dbc2ba57 100644
--- a/src/clblast_netlib_c.cpp
+++ b/src/clblast_netlib_c.cpp
@@ -25,7 +25,7 @@ using double2 = clblast::double2;
// Option to make OpenCL device and context static to avoid re-creation upon multiple calls to the
// Netlib API. Disadvantage is that they are not cleaned-up until program termination.
-#ifdef NETLIB_STATIC_OPENCL
+#ifdef NETLIB_PERSISTENT_OPENCL
#define OPTIONAL_STATIC static
#else
#define OPTIONAL_STATIC