summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCNugteren <web@cedricnugteren.nl>2015-07-12 16:57:09 +0200
committerCNugteren <web@cedricnugteren.nl>2015-07-12 16:57:09 +0200
commitaa852bbe67a7dc9018afd7d1349184f0284d215c (patch)
tree2238271b288f88d3990fe952960b8ee392eafb4b
parent721546e64a32703b0a424f89919a55988c2b4172 (diff)
Added subfolders for the level1/2/3 routines
-rw-r--r--CMakeLists.txt47
-rw-r--r--include/internal/routines/level1/xaxpy.h (renamed from include/internal/routines/xaxpy.h)0
-rw-r--r--include/internal/routines/level2/xgemv.h (renamed from include/internal/routines/xgemv.h)0
-rw-r--r--include/internal/routines/level3/xgemm.h (renamed from include/internal/routines/xgemm.h)0
-rw-r--r--include/internal/routines/level3/xhemm.h (renamed from include/internal/routines/xhemm.h)2
-rw-r--r--include/internal/routines/level3/xher2k.h (renamed from include/internal/routines/xher2k.h)0
-rw-r--r--include/internal/routines/level3/xherk.h (renamed from include/internal/routines/xherk.h)0
-rw-r--r--include/internal/routines/level3/xsymm.h (renamed from include/internal/routines/xsymm.h)2
-rw-r--r--include/internal/routines/level3/xsyr2k.h (renamed from include/internal/routines/xsyr2k.h)0
-rw-r--r--include/internal/routines/level3/xsyrk.h (renamed from include/internal/routines/xsyrk.h)0
-rw-r--r--include/internal/routines/level3/xtrmm.h (renamed from include/internal/routines/xtrmm.h)2
-rw-r--r--src/clblast.cc20
-rw-r--r--src/routines/level1/xaxpy.cc (renamed from src/routines/xaxpy.cc)2
-rw-r--r--src/routines/level2/xgemv.cc (renamed from src/routines/xgemv.cc)2
-rw-r--r--src/routines/level3/xgemm.cc (renamed from src/routines/xgemm.cc)2
-rw-r--r--src/routines/level3/xhemm.cc (renamed from src/routines/xhemm.cc)2
-rw-r--r--src/routines/level3/xher2k.cc (renamed from src/routines/xher2k.cc)2
-rw-r--r--src/routines/level3/xherk.cc (renamed from src/routines/xherk.cc)2
-rw-r--r--src/routines/level3/xsymm.cc (renamed from src/routines/xsymm.cc)2
-rw-r--r--src/routines/level3/xsyr2k.cc (renamed from src/routines/xsyr2k.cc)2
-rw-r--r--src/routines/level3/xsyrk.cc (renamed from src/routines/xsyrk.cc)2
-rw-r--r--src/routines/level3/xtrmm.cc (renamed from src/routines/xtrmm.cc)2
-rw-r--r--test/correctness/routines/level1/xaxpy.cc (renamed from test/correctness/routines/xaxpy.cc)2
-rw-r--r--test/correctness/routines/level2/xgemv.cc (renamed from test/correctness/routines/xgemv.cc)2
-rw-r--r--test/correctness/routines/level3/xgemm.cc (renamed from test/correctness/routines/xgemm.cc)2
-rw-r--r--test/correctness/routines/level3/xhemm.cc (renamed from test/correctness/routines/xhemm.cc)2
-rw-r--r--test/correctness/routines/level3/xher2k.cc (renamed from test/correctness/routines/xher2k.cc)2
-rw-r--r--test/correctness/routines/level3/xherk.cc (renamed from test/correctness/routines/xherk.cc)2
-rw-r--r--test/correctness/routines/level3/xsymm.cc (renamed from test/correctness/routines/xsymm.cc)2
-rw-r--r--test/correctness/routines/level3/xsyr2k.cc (renamed from test/correctness/routines/xsyr2k.cc)2
-rw-r--r--test/correctness/routines/level3/xsyrk.cc (renamed from test/correctness/routines/xsyrk.cc)2
-rw-r--r--test/correctness/routines/level3/xtrmm.cc (renamed from test/correctness/routines/xtrmm.cc)2
-rw-r--r--test/performance/routines/level1/xaxpy.cc (renamed from test/performance/routines/xaxpy.cc)2
-rw-r--r--test/performance/routines/level2/xgemv.cc (renamed from test/performance/routines/xgemv.cc)2
-rw-r--r--test/performance/routines/level3/xgemm.cc (renamed from test/performance/routines/xgemm.cc)2
-rw-r--r--test/performance/routines/level3/xhemm.cc (renamed from test/performance/routines/xhemm.cc)2
-rw-r--r--test/performance/routines/level3/xher2k.cc (renamed from test/performance/routines/xher2k.cc)2
-rw-r--r--test/performance/routines/level3/xherk.cc (renamed from test/performance/routines/xherk.cc)2
-rw-r--r--test/performance/routines/level3/xsymm.cc (renamed from test/performance/routines/xsymm.cc)2
-rw-r--r--test/performance/routines/level3/xsyr2k.cc (renamed from test/performance/routines/xsyr2k.cc)2
-rw-r--r--test/performance/routines/level3/xsyrk.cc (renamed from test/performance/routines/xsyrk.cc)2
-rw-r--r--test/performance/routines/level3/xtrmm.cc (renamed from test/performance/routines/xtrmm.cc)2
-rw-r--r--test/routines/level1/xaxpy.h (renamed from test/routines/xaxpy.h)0
-rw-r--r--test/routines/level2/xgemv.h (renamed from test/routines/xgemv.h)0
-rw-r--r--test/routines/level3/xgemm.h (renamed from test/routines/xgemm.h)0
-rw-r--r--test/routines/level3/xhemm.h (renamed from test/routines/xhemm.h)0
-rw-r--r--test/routines/level3/xher2k.h (renamed from test/routines/xher2k.h)0
-rw-r--r--test/routines/level3/xherk.h (renamed from test/routines/xherk.h)0
-rw-r--r--test/routines/level3/xsymm.h (renamed from test/routines/xsymm.h)0
-rw-r--r--test/routines/level3/xsyr2k.h (renamed from test/routines/xsyr2k.h)0
-rw-r--r--test/routines/level3/xsyrk.h (renamed from test/routines/xsyrk.h)0
-rw-r--r--test/routines/level3/xtrmm.h (renamed from test/routines/xtrmm.h)0
52 files changed, 79 insertions, 54 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b2c5657..c97ddd5b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -95,17 +95,23 @@ include_directories(${clblast_SOURCE_DIR}/include ${OPENCL_INCLUDE_DIRS})
# Sets the supported routines and the used kernels. New routines and kernels should be added here.
set(KERNELS copy pad transpose padtranspose xaxpy xgemv xgemm)
set(SAMPLE_PROGRAMS sgemm)
-set(ROUTINES
- xaxpy
- xgemv
- xgemm xsymm xhemm xsyrk xherk xsyr2k xher2k xtrmm)
+set(LEVEL1_ROUTINES xaxpy)
+set(LEVEL2_ROUTINES xgemv)
+set(LEVEL3_ROUTINES xgemm xsymm xhemm xsyrk xherk xsyr2k xher2k xtrmm)
+set(ROUTINES ${LEVEL1_ROUTINES} ${LEVEL2_ROUTINES} ${LEVEL3_ROUTINES})
# ==================================================================================================
# Gathers all source-files
set(SOURCES src/clblast.cc src/database.cc src/routine.cc src/utilities.cc)
-foreach(ROUTINE ${ROUTINES})
- set(SOURCES ${SOURCES} src/routines/${ROUTINE}.cc)
+foreach(ROUTINE ${LEVEL1_ROUTINES})
+ set(SOURCES ${SOURCES} src/routines/level1/${ROUTINE}.cc)
+endforeach()
+foreach(ROUTINE ${LEVEL2_ROUTINES})
+ set(SOURCES ${SOURCES} src/routines/level2/${ROUTINE}.cc)
+endforeach()
+foreach(ROUTINE ${LEVEL3_ROUTINES})
+ set(SOURCES ${SOURCES} src/routines/level3/${ROUTINE}.cc)
endforeach()
# Creates and links the library
@@ -172,10 +178,19 @@ if(TESTS)
test/correctness/tester.cc test/correctness/testblas.cc)
# Compiles the correctness-tests
+ foreach(ROUTINE ${LEVEL1_ROUTINES})
+ add_executable(test_${ROUTINE} $<TARGET_OBJECTS:test_correctness_common>
+ test/correctness/routines/level1/${ROUTINE}.cc)
+ endforeach()
+ foreach(ROUTINE ${LEVEL2_ROUTINES})
+ add_executable(test_${ROUTINE} $<TARGET_OBJECTS:test_correctness_common>
+ test/correctness/routines/level2/${ROUTINE}.cc)
+ endforeach()
+ foreach(ROUTINE ${LEVEL3_ROUTINES})
+ add_executable(test_${ROUTINE} $<TARGET_OBJECTS:test_correctness_common>
+ test/correctness/routines/level3/${ROUTINE}.cc)
+ endforeach()
foreach(ROUTINE ${ROUTINES})
- add_executable(test_${ROUTINE}
- $<TARGET_OBJECTS:test_correctness_common>
- test/correctness/routines/${ROUTINE}.cc)
target_link_libraries(test_${ROUTINE} clBLAS clblast ${OPENCL_LIBRARIES})
install(TARGETS test_${ROUTINE} DESTINATION bin)
endforeach()
@@ -184,9 +199,19 @@ if(TESTS)
add_library(test_performance_common OBJECT test/performance/client.cc)
# Compiles the performance-tests
- foreach(ROUTINE ${ROUTINES})
+ foreach(ROUTINE ${LEVEL1_ROUTINES})
add_executable(client_${ROUTINE} $<TARGET_OBJECTS:test_performance_common>
- test/performance/routines/${ROUTINE}.cc)
+ test/performance/routines/level1/${ROUTINE}.cc)
+ endforeach()
+ foreach(ROUTINE ${LEVEL2_ROUTINES})
+ add_executable(client_${ROUTINE} $<TARGET_OBJECTS:test_performance_common>
+ test/performance/routines/level2/${ROUTINE}.cc)
+ endforeach()
+ foreach(ROUTINE ${LEVEL3_ROUTINES})
+ add_executable(client_${ROUTINE} $<TARGET_OBJECTS:test_performance_common>
+ test/performance/routines/level3/${ROUTINE}.cc)
+ endforeach()
+ foreach(ROUTINE ${ROUTINES})
target_link_libraries(client_${ROUTINE} clBLAS clblast ${OPENCL_LIBRARIES})
install(TARGETS client_${ROUTINE} DESTINATION bin)
endforeach()
diff --git a/include/internal/routines/xaxpy.h b/include/internal/routines/level1/xaxpy.h
index e548e553..e548e553 100644
--- a/include/internal/routines/xaxpy.h
+++ b/include/internal/routines/level1/xaxpy.h
diff --git a/include/internal/routines/xgemv.h b/include/internal/routines/level2/xgemv.h
index a3109036..a3109036 100644
--- a/include/internal/routines/xgemv.h
+++ b/include/internal/routines/level2/xgemv.h
diff --git a/include/internal/routines/xgemm.h b/include/internal/routines/level3/xgemm.h
index 7ad4fcfb..7ad4fcfb 100644
--- a/include/internal/routines/xgemm.h
+++ b/include/internal/routines/level3/xgemm.h
diff --git a/include/internal/routines/xhemm.h b/include/internal/routines/level3/xhemm.h
index 1b1a0dfa..6cc9d9ec 100644
--- a/include/internal/routines/xhemm.h
+++ b/include/internal/routines/level3/xhemm.h
@@ -15,7 +15,7 @@
#ifndef CLBLAST_ROUTINES_XHEMM_H_
#define CLBLAST_ROUTINES_XHEMM_H_
-#include "internal/routines/xgemm.h"
+#include "internal/routines/level3/xgemm.h"
namespace clblast {
// =================================================================================================
diff --git a/include/internal/routines/xher2k.h b/include/internal/routines/level3/xher2k.h
index 1836a812..1836a812 100644
--- a/include/internal/routines/xher2k.h
+++ b/include/internal/routines/level3/xher2k.h
diff --git a/include/internal/routines/xherk.h b/include/internal/routines/level3/xherk.h
index 9b361254..9b361254 100644
--- a/include/internal/routines/xherk.h
+++ b/include/internal/routines/level3/xherk.h
diff --git a/include/internal/routines/xsymm.h b/include/internal/routines/level3/xsymm.h
index c6545164..2028ceea 100644
--- a/include/internal/routines/xsymm.h
+++ b/include/internal/routines/level3/xsymm.h
@@ -17,7 +17,7 @@
#ifndef CLBLAST_ROUTINES_XSYMM_H_
#define CLBLAST_ROUTINES_XSYMM_H_
-#include "internal/routines/xgemm.h"
+#include "internal/routines/level3/xgemm.h"
namespace clblast {
// =================================================================================================
diff --git a/include/internal/routines/xsyr2k.h b/include/internal/routines/level3/xsyr2k.h
index 6259313c..6259313c 100644
--- a/include/internal/routines/xsyr2k.h
+++ b/include/internal/routines/level3/xsyr2k.h
diff --git a/include/internal/routines/xsyrk.h b/include/internal/routines/level3/xsyrk.h
index 3dab731f..3dab731f 100644
--- a/include/internal/routines/xsyrk.h
+++ b/include/internal/routines/level3/xsyrk.h
diff --git a/include/internal/routines/xtrmm.h b/include/internal/routines/level3/xtrmm.h
index af9f0266..4f49bebd 100644
--- a/include/internal/routines/xtrmm.h
+++ b/include/internal/routines/level3/xtrmm.h
@@ -16,7 +16,7 @@
#ifndef CLBLAST_ROUTINES_XTRMM_H_
#define CLBLAST_ROUTINES_XTRMM_H_
-#include "internal/routines/xgemm.h"
+#include "internal/routines/level3/xgemm.h"
namespace clblast {
// =================================================================================================
diff --git a/src/clblast.cc b/src/clblast.cc
index 23046b01..b5d53ee6 100644
--- a/src/clblast.cc
+++ b/src/clblast.cc
@@ -18,20 +18,20 @@
#include "clblast.h"
// BLAS level-1 includes
-#include "internal/routines/xaxpy.h"
+#include "internal/routines/level1/xaxpy.h"
// BLAS level-2 includes
-#include "internal/routines/xgemv.h"
+#include "internal/routines/level2/xgemv.h"
// BLAS level-3 includes
-#include "internal/routines/xgemm.h"
-#include "internal/routines/xsymm.h"
-#include "internal/routines/xhemm.h"
-#include "internal/routines/xsyrk.h"
-#include "internal/routines/xherk.h"
-#include "internal/routines/xsyr2k.h"
-#include "internal/routines/xher2k.h"
-#include "internal/routines/xtrmm.h"
+#include "internal/routines/level3/xgemm.h"
+#include "internal/routines/level3/xsymm.h"
+#include "internal/routines/level3/xhemm.h"
+#include "internal/routines/level3/xsyrk.h"
+#include "internal/routines/level3/xherk.h"
+#include "internal/routines/level3/xsyr2k.h"
+#include "internal/routines/level3/xher2k.h"
+#include "internal/routines/level3/xtrmm.h"
namespace clblast {
// =================================================================================================
diff --git a/src/routines/xaxpy.cc b/src/routines/level1/xaxpy.cc
index b68458da..fba36851 100644
--- a/src/routines/xaxpy.cc
+++ b/src/routines/level1/xaxpy.cc
@@ -11,7 +11,7 @@
//
// =================================================================================================
-#include "internal/routines/xaxpy.h"
+#include "internal/routines/level1/xaxpy.h"
#include <string>
#include <vector>
diff --git a/src/routines/xgemv.cc b/src/routines/level2/xgemv.cc
index 1868dec4..181337b6 100644
--- a/src/routines/xgemv.cc
+++ b/src/routines/level2/xgemv.cc
@@ -11,7 +11,7 @@
//
// =================================================================================================
-#include "internal/routines/xgemv.h"
+#include "internal/routines/level2/xgemv.h"
#include <string>
#include <vector>
diff --git a/src/routines/xgemm.cc b/src/routines/level3/xgemm.cc
index c8674282..f4a9f737 100644
--- a/src/routines/xgemm.cc
+++ b/src/routines/level3/xgemm.cc
@@ -11,7 +11,7 @@
//
// =================================================================================================
-#include "internal/routines/xgemm.h"
+#include "internal/routines/level3/xgemm.h"
#include <string>
#include <vector>
diff --git a/src/routines/xhemm.cc b/src/routines/level3/xhemm.cc
index 73f769ed..bc257c44 100644
--- a/src/routines/xhemm.cc
+++ b/src/routines/level3/xhemm.cc
@@ -11,7 +11,7 @@
//
// =================================================================================================
-#include "internal/routines/xhemm.h"
+#include "internal/routines/level3/xhemm.h"
#include <string>
#include <vector>
diff --git a/src/routines/xher2k.cc b/src/routines/level3/xher2k.cc
index b19b743b..6d33a0e1 100644
--- a/src/routines/xher2k.cc
+++ b/src/routines/level3/xher2k.cc
@@ -11,7 +11,7 @@
//
// =================================================================================================
-#include "internal/routines/xher2k.h"
+#include "internal/routines/level3/xher2k.h"
#include <string>
#include <vector>
diff --git a/src/routines/xherk.cc b/src/routines/level3/xherk.cc
index 6bc9cd6c..8fae294f 100644
--- a/src/routines/xherk.cc
+++ b/src/routines/level3/xherk.cc
@@ -11,7 +11,7 @@
//
// =================================================================================================
-#include "internal/routines/xherk.h"
+#include "internal/routines/level3/xherk.h"
#include <string>
#include <vector>
diff --git a/src/routines/xsymm.cc b/src/routines/level3/xsymm.cc
index b39eb24d..1d17f0eb 100644
--- a/src/routines/xsymm.cc
+++ b/src/routines/level3/xsymm.cc
@@ -11,7 +11,7 @@
//
// =================================================================================================
-#include "internal/routines/xsymm.h"
+#include "internal/routines/level3/xsymm.h"
#include <string>
#include <vector>
diff --git a/src/routines/xsyr2k.cc b/src/routines/level3/xsyr2k.cc
index abb8b7eb..d54f2fc1 100644
--- a/src/routines/xsyr2k.cc
+++ b/src/routines/level3/xsyr2k.cc
@@ -11,7 +11,7 @@
//
// =================================================================================================
-#include "internal/routines/xsyr2k.h"
+#include "internal/routines/level3/xsyr2k.h"
#include <string>
#include <vector>
diff --git a/src/routines/xsyrk.cc b/src/routines/level3/xsyrk.cc
index 3efa0598..bb952410 100644
--- a/src/routines/xsyrk.cc
+++ b/src/routines/level3/xsyrk.cc
@@ -11,7 +11,7 @@
//
// =================================================================================================
-#include "internal/routines/xsyrk.h"
+#include "internal/routines/level3/xsyrk.h"
#include <string>
#include <vector>
diff --git a/src/routines/xtrmm.cc b/src/routines/level3/xtrmm.cc
index 543df844..52f272e3 100644
--- a/src/routines/xtrmm.cc
+++ b/src/routines/level3/xtrmm.cc
@@ -11,7 +11,7 @@
//
// =================================================================================================
-#include "internal/routines/xtrmm.h"
+#include "internal/routines/level3/xtrmm.h"
#include <string>
#include <vector>
diff --git a/test/correctness/routines/xaxpy.cc b/test/correctness/routines/level1/xaxpy.cc
index cf23ca9f..ac44caec 100644
--- a/test/correctness/routines/xaxpy.cc
+++ b/test/correctness/routines/level1/xaxpy.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "correctness/testblas.h"
-#include "routines/xaxpy.h"
+#include "routines/level1/xaxpy.h"
namespace clblast {
// =================================================================================================
diff --git a/test/correctness/routines/xgemv.cc b/test/correctness/routines/level2/xgemv.cc
index 50ce4699..4e6942cc 100644
--- a/test/correctness/routines/xgemv.cc
+++ b/test/correctness/routines/level2/xgemv.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "correctness/testblas.h"
-#include "routines/xgemv.h"
+#include "routines/level2/xgemv.h"
namespace clblast {
// =================================================================================================
diff --git a/test/correctness/routines/xgemm.cc b/test/correctness/routines/level3/xgemm.cc
index 8a50e1ca..c1ce8fe2 100644
--- a/test/correctness/routines/xgemm.cc
+++ b/test/correctness/routines/level3/xgemm.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "correctness/testblas.h"
-#include "routines/xgemm.h"
+#include "routines/level3/xgemm.h"
namespace clblast {
// =================================================================================================
diff --git a/test/correctness/routines/xhemm.cc b/test/correctness/routines/level3/xhemm.cc
index e8c82f65..4d66a57f 100644
--- a/test/correctness/routines/xhemm.cc
+++ b/test/correctness/routines/level3/xhemm.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "correctness/testblas.h"
-#include "routines/xhemm.h"
+#include "routines/level3/xhemm.h"
namespace clblast {
// =================================================================================================
diff --git a/test/correctness/routines/xher2k.cc b/test/correctness/routines/level3/xher2k.cc
index 7c0e5a92..ba5260fb 100644
--- a/test/correctness/routines/xher2k.cc
+++ b/test/correctness/routines/level3/xher2k.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "correctness/testblas.h"
-#include "routines/xher2k.h"
+#include "routines/level3/xher2k.h"
namespace clblast {
// =================================================================================================
diff --git a/test/correctness/routines/xherk.cc b/test/correctness/routines/level3/xherk.cc
index dc5c6caf..7a4a7278 100644
--- a/test/correctness/routines/xherk.cc
+++ b/test/correctness/routines/level3/xherk.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "correctness/testblas.h"
-#include "routines/xherk.h"
+#include "routines/level3/xherk.h"
namespace clblast {
// =================================================================================================
diff --git a/test/correctness/routines/xsymm.cc b/test/correctness/routines/level3/xsymm.cc
index a919a056..851efff2 100644
--- a/test/correctness/routines/xsymm.cc
+++ b/test/correctness/routines/level3/xsymm.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "correctness/testblas.h"
-#include "routines/xsymm.h"
+#include "routines/level3/xsymm.h"
namespace clblast {
// =================================================================================================
diff --git a/test/correctness/routines/xsyr2k.cc b/test/correctness/routines/level3/xsyr2k.cc
index 736aa4e5..61ea59a3 100644
--- a/test/correctness/routines/xsyr2k.cc
+++ b/test/correctness/routines/level3/xsyr2k.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "correctness/testblas.h"
-#include "routines/xsyr2k.h"
+#include "routines/level3/xsyr2k.h"
namespace clblast {
// =================================================================================================
diff --git a/test/correctness/routines/xsyrk.cc b/test/correctness/routines/level3/xsyrk.cc
index a62a0ebf..126e201b 100644
--- a/test/correctness/routines/xsyrk.cc
+++ b/test/correctness/routines/level3/xsyrk.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "correctness/testblas.h"
-#include "routines/xsyrk.h"
+#include "routines/level3/xsyrk.h"
namespace clblast {
// =================================================================================================
diff --git a/test/correctness/routines/xtrmm.cc b/test/correctness/routines/level3/xtrmm.cc
index 0bb6294c..5f04bb18 100644
--- a/test/correctness/routines/xtrmm.cc
+++ b/test/correctness/routines/level3/xtrmm.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "correctness/testblas.h"
-#include "routines/xtrmm.h"
+#include "routines/level3/xtrmm.h"
namespace clblast {
// =================================================================================================
diff --git a/test/performance/routines/xaxpy.cc b/test/performance/routines/level1/xaxpy.cc
index 6a2b96c1..fe90c697 100644
--- a/test/performance/routines/xaxpy.cc
+++ b/test/performance/routines/level1/xaxpy.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "performance/client.h"
-#include "routines/xaxpy.h"
+#include "routines/level1/xaxpy.h"
// =================================================================================================
diff --git a/test/performance/routines/xgemv.cc b/test/performance/routines/level2/xgemv.cc
index 6f69ef21..376c6c33 100644
--- a/test/performance/routines/xgemv.cc
+++ b/test/performance/routines/level2/xgemv.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "performance/client.h"
-#include "routines/xgemv.h"
+#include "routines/level2/xgemv.h"
// =================================================================================================
diff --git a/test/performance/routines/xgemm.cc b/test/performance/routines/level3/xgemm.cc
index 9a02e595..c45c238f 100644
--- a/test/performance/routines/xgemm.cc
+++ b/test/performance/routines/level3/xgemm.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "performance/client.h"
-#include "routines/xgemm.h"
+#include "routines/level3/xgemm.h"
// =================================================================================================
diff --git a/test/performance/routines/xhemm.cc b/test/performance/routines/level3/xhemm.cc
index 34798d8d..d215653b 100644
--- a/test/performance/routines/xhemm.cc
+++ b/test/performance/routines/level3/xhemm.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "performance/client.h"
-#include "routines/xhemm.h"
+#include "routines/level3/xhemm.h"
// =================================================================================================
diff --git a/test/performance/routines/xher2k.cc b/test/performance/routines/level3/xher2k.cc
index 1b505737..2e1f248a 100644
--- a/test/performance/routines/xher2k.cc
+++ b/test/performance/routines/level3/xher2k.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "performance/client.h"
-#include "routines/xher2k.h"
+#include "routines/level3/xher2k.h"
// =================================================================================================
diff --git a/test/performance/routines/xherk.cc b/test/performance/routines/level3/xherk.cc
index ce18152e..4386f78c 100644
--- a/test/performance/routines/xherk.cc
+++ b/test/performance/routines/level3/xherk.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "performance/client.h"
-#include "routines/xherk.h"
+#include "routines/level3/xherk.h"
// =================================================================================================
diff --git a/test/performance/routines/xsymm.cc b/test/performance/routines/level3/xsymm.cc
index 8738ceda..bd014cee 100644
--- a/test/performance/routines/xsymm.cc
+++ b/test/performance/routines/level3/xsymm.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "performance/client.h"
-#include "routines/xsymm.h"
+#include "routines/level3/xsymm.h"
// =================================================================================================
diff --git a/test/performance/routines/xsyr2k.cc b/test/performance/routines/level3/xsyr2k.cc
index e4c76229..1261be88 100644
--- a/test/performance/routines/xsyr2k.cc
+++ b/test/performance/routines/level3/xsyr2k.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "performance/client.h"
-#include "routines/xsyr2k.h"
+#include "routines/level3/xsyr2k.h"
// =================================================================================================
diff --git a/test/performance/routines/xsyrk.cc b/test/performance/routines/level3/xsyrk.cc
index 53fecb69..5799130f 100644
--- a/test/performance/routines/xsyrk.cc
+++ b/test/performance/routines/level3/xsyrk.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "performance/client.h"
-#include "routines/xsyrk.h"
+#include "routines/level3/xsyrk.h"
// =================================================================================================
diff --git a/test/performance/routines/xtrmm.cc b/test/performance/routines/level3/xtrmm.cc
index 2ab9ce77..c30866e9 100644
--- a/test/performance/routines/xtrmm.cc
+++ b/test/performance/routines/level3/xtrmm.cc
@@ -12,7 +12,7 @@
// =================================================================================================
#include "performance/client.h"
-#include "routines/xtrmm.h"
+#include "routines/level3/xtrmm.h"
// =================================================================================================
diff --git a/test/routines/xaxpy.h b/test/routines/level1/xaxpy.h
index 6ce5d7e2..6ce5d7e2 100644
--- a/test/routines/xaxpy.h
+++ b/test/routines/level1/xaxpy.h
diff --git a/test/routines/xgemv.h b/test/routines/level2/xgemv.h
index 73f7d76e..73f7d76e 100644
--- a/test/routines/xgemv.h
+++ b/test/routines/level2/xgemv.h
diff --git a/test/routines/xgemm.h b/test/routines/level3/xgemm.h
index 86a304d1..86a304d1 100644
--- a/test/routines/xgemm.h
+++ b/test/routines/level3/xgemm.h
diff --git a/test/routines/xhemm.h b/test/routines/level3/xhemm.h
index 75878b06..75878b06 100644
--- a/test/routines/xhemm.h
+++ b/test/routines/level3/xhemm.h
diff --git a/test/routines/xher2k.h b/test/routines/level3/xher2k.h
index f13e8a62..f13e8a62 100644
--- a/test/routines/xher2k.h
+++ b/test/routines/level3/xher2k.h
diff --git a/test/routines/xherk.h b/test/routines/level3/xherk.h
index 780b9b52..780b9b52 100644
--- a/test/routines/xherk.h
+++ b/test/routines/level3/xherk.h
diff --git a/test/routines/xsymm.h b/test/routines/level3/xsymm.h
index 10476349..10476349 100644
--- a/test/routines/xsymm.h
+++ b/test/routines/level3/xsymm.h
diff --git a/test/routines/xsyr2k.h b/test/routines/level3/xsyr2k.h
index f3b1b542..f3b1b542 100644
--- a/test/routines/xsyr2k.h
+++ b/test/routines/level3/xsyr2k.h
diff --git a/test/routines/xsyrk.h b/test/routines/level3/xsyrk.h
index 2ec9fb65..2ec9fb65 100644
--- a/test/routines/xsyrk.h
+++ b/test/routines/level3/xsyrk.h
diff --git a/test/routines/xtrmm.h b/test/routines/level3/xtrmm.h
index 7b7e7af1..7b7e7af1 100644
--- a/test/routines/xtrmm.h
+++ b/test/routines/level3/xtrmm.h