summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2018-07-14 12:29:06 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2018-07-14 12:29:06 +0200
commitdb179a1e40a3ea37e5dd8ad293aad9b651947668 (patch)
tree287839c7a6fccb3fdfa4f157ce9018f35e897cc7
parentf72620f47453a98b199f94ca39ff7d410d571684 (diff)
Updated to CLBlast version 1.4.1
-rw-r--r--.appveyor.yml4
-rw-r--r--.travis.yml2
-rw-r--r--CHANGELOG2
-rw-r--r--CMakeLists.txt2
-rw-r--r--doc/installation.md1
5 files changed, 6 insertions, 5 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index db99d08a..f07f2971 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -57,8 +57,8 @@ build_script:
after_build:
- ps: pushd $env:CLBLAST_BUILD
- - 7z a CLBlast-1.4.0-Windows-x64.zip .\install_dir\*
- - ps: mv CLBlast-1.4.0-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
+ - 7z a CLBlast-1.4.1-Windows-x64.zip .\install_dir\*
+ - ps: mv CLBlast-1.4.1-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
artifacts:
- path: '*.zip'
diff --git a/.travis.yml b/.travis.yml
index 17d9048c..fc60826c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -21,7 +21,7 @@ matrix:
env:
global:
- - CLBLAST_VERSION=1.4.0
+ - CLBLAST_VERSION=1.4.1
- CLBLAST_ROOT=${TRAVIS_BUILD_DIR}/bin/clblast
- CLBLAST_INSTALL=${TRAVIS_BUILD_DIR}/bin/CLBlast-${CLBLAST_VERSION}
- CLBLAST_TAR=CLBlast-${CLBLAST_VERSION}-${TRAVIS_OS_NAME}-x64.tar.gz
diff --git a/CHANGELOG b/CHANGELOG
index 4ed1a72a..4ad70a95 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,5 +1,5 @@
-Development (next version)
+Version 1.4.1
- Fixed an access violation under Windows upon releasing the OpenCL program when the driver is already unloaded
- Fixed an issue with double cl_program release in the CLBlast caching system
- Added tuned parameters for various devices (see doc/tuning.md)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4bf84520..fea08287 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,7 +22,7 @@ endif()
project("clblast" C CXX)
set(clblast_VERSION_MAJOR 1)
set(clblast_VERSION_MINOR 4)
-set(clblast_VERSION_PATCH 0)
+set(clblast_VERSION_PATCH 1)
set(clblast_VERSION "${clblast_VERSION_MAJOR}.${clblast_VERSION_MINOR}.${clblast_VERSION_PATCH}")
set(clblast_SOVERSION ${clblast_VERSION_MAJOR})
diff --git a/doc/installation.md b/doc/installation.md
index 8606de09..70c69321 100644
--- a/doc/installation.md
+++ b/doc/installation.md
@@ -25,6 +25,7 @@ The pre-requisites for compilation of CLBlast are kept as minimal as possible. A
- Mesa Clover
- ARM Mali OpenCL
- Vivante OpenCL
+ - POCL
Using pre-built packages