summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2018-05-19 12:48:59 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2018-05-19 12:48:59 +0200
commit66583b3cdac143bd43da1ee6f0f5af012b8ca39a (patch)
treecd2b571da58a9259476f7b028cf6b63ad92a4f3a /CMakeLists.txt
parent637e49e134df2e6be3e5ce4901bbc8803535e14d (diff)
The GEMM routine tuner now loads kernel JSON tuning results from disk if available; now run part of alltuners target
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0715b866..7f3d258a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -388,6 +388,7 @@ if(TUNERS)
src/utilities/clblast_exceptions.cpp
src/utilities/timing.cpp
src/utilities/utilities.cpp
+ test/test_utilities.cpp
src/tuning/configurations.cpp
src/tuning/tuning.cpp
src/kernel_preprocessor.cpp)
@@ -396,6 +397,7 @@ if(TUNERS)
src/utilities/clblast_exceptions.hpp
src/utilities/timing.hpp
src/utilities/utilities.hpp
+ test/test_utilities.hpp
src/tuning/configurations.hpp
src/tuning/tuning.hpp
src/tuning/routines/routine_tuner.hpp
@@ -439,6 +441,12 @@ if(TUNERS)
endforeach()
set(ALLTUNERSDEPENDS clblast_tuner_${KERNEL})
endforeach()
+ foreach(ROUTINE_TUNER ${ROUTINE_TUNERS})
+ foreach(PRECISION ${PRECISIONS})
+ set(ALLTUNERS ${ALLTUNERS} COMMAND clblast_tuner_routine_${ROUTINE_TUNER} -precision ${PRECISION})
+ endforeach()
+ set(ALLTUNERSDEPENDS clblast_tuner_routine_${ROUTINE_TUNER})
+ endforeach()
add_custom_target(alltuners ${ALLTUNERS} DEPENDS ${ALLTUNERSDEPENDS})
endif()