summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2016-10-21 21:00:07 +0200
committerGitHub <noreply@github.com>2016-10-21 21:00:07 +0200
commit597974b40d52d9cd199e5189d6d55cd12c841e63 (patch)
tree5e98094a7681ea7dd3fc834148541f4fcd818fbb /CMakeLists.txt
parent370105148b6c97f078ac0a0b4a08239c8e44474d (diff)
parent3797d144cc8d7cf3de55f4804cb5e81e2436571f (diff)
Merge pull request #118 from matze/add-pkg-config
Generate and install pkg-config description
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c882575e..ae78b5a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -218,6 +218,14 @@ install(FILES include/clblast_half.h DESTINATION include)
# Installs the config for find_package in dependent projects
install(EXPORT CLBlast DESTINATION lib/cmake/CLBLast FILE CLBlastConfig.cmake)
+# Install pkg-config file on Linux
+if(UNIX)
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/src/clblast.pc.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/clblast.pc" @ONLY IMMEDIATE)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/clblast.pc
+ DESTINATION lib/pkgconfig)
+endif()
+
# ==================================================================================================
# Sets a default platform ($CLBLAST_PLATFORM) and device ($CLBLAST_DEVICE) to run tuners and tests