summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Shapovalov <intelfx@intelfx.name>2016-09-13 16:12:30 +0300
committerIvan Shapovalov <intelfx@intelfx.name>2016-09-13 16:12:30 +0300
commit9095537a6a5199e2dc3824381481af790d4e8f27 (patch)
tree251f39d4d996d64d601e95d200e04fc508e3a357 /CMakeLists.txt
parent4ce584a01404055fdb23f78b4ac359394b559ea1 (diff)
CMakeLists.txt: use -Wno-ignored-attributes to silence unfixable warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7393c6e7..c10f66a3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,6 +75,12 @@ else()
if(CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4.9.0)
set(FLAGS "${FLAGS} -Wno-attributes -Wno-unused-variable")
endif()
+ if(CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 6.0.0)
+ # GCC does not support attributes on template arguments
+ # in particular we hit this with the alignment attributes on cl_XXX types
+ # which are then used to instantiate various templates in CLBlast
+ set(FLAGS "${FLAGS} -Wno-ignored-attributes")
+ endif()
elseif(CMAKE_CXX_COMPILER_ID MATCHES Clang)
set(FLAGS "${FLAGS} -Wextra -Wno-c++98-compat -Wno-c++98-compat-pedantic -Wno-padded")
set(FLAGS "${FLAGS} -Wno-missing-prototypes -Wno-float-equal -Wno-switch-enum -Wno-switch")