summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2018-08-07 22:41:06 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2018-08-07 22:41:06 +0200
commit9d9f09fce9d42247701c16d89ca356cdd3a76b4b (patch)
tree2401badea0664b405e1fd62c0d35395d98eca652 /CMakeLists.txt
parentfe639455bd1e02c22c459f9e29654f82652e0a97 (diff)
Name change of setting to NETLIB_PERSISTENT_OPENCL
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 806b4b26..fd201021 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,12 +36,12 @@ option(CUBLAS "Enables performance comparison against cuBLAS on NVIDIA GPUs" OFF
# The optional Netlib API for CLBlast
option(NETLIB "Enable compilation of the CBLAS Netlib API" OFF)
-option(NETLIB_STATIC_OPENCL "Makes OpenCL device and context in the CBLAS Netlib API static" OFF)
+option(NETLIB_PERSISTENT_OPENCL "Makes OpenCL device and context in the CBLAS Netlib API static" OFF)
if(NETLIB)
message("-- Building the Netlib API of CLBlast")
- if(NETLIB_STATIC_OPENCL)
+ if(NETLIB_PERSISTENT_OPENCL)
message(" ^^ while using static variables for OpenCL device and context")
- add_definitions(-DNETLIB_STATIC_OPENCL)
+ add_definitions(-DNETLIB_PERSISTENT_OPENCL)
endif()
endif()