summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2017-06-26 21:38:04 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2017-06-26 21:38:04 +0200
commitce528a9d39a976760f84c194016f22fc493a5d57 (patch)
treedc0bd7d633f18ad3281bae9c68b48b9818b573e3 /CMakeLists.txt
parenta823edb65ffadd21bb825b9e2184e09a06879c1d (diff)
Fixed and suppresses several warnings for MSVC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 94d9cbc2..e549a63a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,7 +77,7 @@ endif(MSVC)
# C++ compiler settings
if(MSVC)
set(FLAGS "/Ot")
- set(FLAGS "${FLAGS} /wd4715")
+ set(FLAGS "${FLAGS} /wd4715 /D_CRT_SECURE_NO_WARNINGS")
else()
set(FLAGS "-std=c++11")
if(VERBOSE)