summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2016-10-25 14:28:52 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2016-10-25 14:28:52 +0200
commitf96fd372bc3087938572ebc55bd1d8e1b7e6f18a (patch)
tree5a3a20fa4fdefd942bfd4dbd6713f687cfe67d5b /CMakeLists.txt
parent3b65eace0a4a48568353da3a86ac46d9ff1f1ffc (diff)
Added initial version of a Netlib CBLAS implementation. TODO: Set correct buffer sizes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5edbd75..d2034617 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -163,6 +163,7 @@ set(PRECISIONS 32 64 3232 6464 16)
# Gathers all source-files
set(SOURCES
+ src/clblast_blas.cpp
src/database/database.cpp
src/routines/common.cpp
src/utilities/clblast_exceptions.cpp
@@ -213,6 +214,7 @@ install(TARGETS clblast EXPORT CLBlast DESTINATION lib)
install(FILES include/clblast.h DESTINATION include)
install(FILES include/clblast_c.h DESTINATION include)
install(FILES include/clblast_half.h DESTINATION include)
+install(FILES include/clblast_blas.h DESTINATION include)
# Installs the config for find_package in dependent projects
install(EXPORT CLBlast DESTINATION lib/cmake/CLBLast FILE CLBlastConfig.cmake)