summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2017-10-28 17:30:29 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2017-10-28 17:30:29 +0200
commit334a26eb12a10b597312db2a1b7de1548cba6327 (patch)
tree3ba07d9afa7f91613767aabfb399965c30f2693e /CMakeLists.txt
parentbd57dfa435dd6c161b758aef2c68404f837ed689 (diff)
Added initial version of a GEMM kernel selection tuner
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3b202c2..73b47637 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -377,6 +377,13 @@ if(TUNERS)
target_include_directories(clblast_tuner_${KERNEL} PUBLIC ${CLTUNE_INCLUDE_DIRS})
install(TARGETS clblast_tuner_${KERNEL} DESTINATION bin)
endforeach()
+ set(ROUTINE_TUNERS xgemm)
+ foreach(ROUTINE_TUNER ${ROUTINE_TUNERS})
+ add_executable(clblast_tuner_routine_${ROUTINE_TUNER} ${TUNERS_COMMON} src/tuning/routines/${ROUTINE_TUNER}.cpp)
+ target_link_libraries(clblast_tuner_routine_${ROUTINE_TUNER} clblast ${CLTUNE_LIBRARIES} ${API_LIBRARIES})
+ target_include_directories(clblast_tuner_routine_${ROUTINE_TUNER} PUBLIC ${CLTUNE_INCLUDE_DIRS})
+ install(TARGETS clblast_tuner_routine_${ROUTINE_TUNER} DESTINATION bin)
+ endforeach()
# Adds 'alltuners' target: runs all tuners for all precisions
set(ALLTUNERS )