summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2023-05-21 17:07:31 +0200
committerGitHub <noreply@github.com>2023-05-21 17:07:31 +0200
commit036684204e01a28bd8056a8c63c91948f3c39006 (patch)
tree40b0a3062ec06826dfc8dd88b0d6f0281d684626 /CMakeLists.txt
parent63eb127bada3a9ef8aa0ab1f48112e8830f74a19 (diff)
Github Actions Windows builds with tests (#472)
* Set CMake CMP0074 policy * Attempt to use pre-compiled OpenBLAS on Windows CI * Fix an issue and add some debugging * Improve FindCBLAS for OpenBLAS on Windows
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 169e6852..8e60bf22 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,9 @@ set(clblast_VERSION_PATCH 3)
set(clblast_VERSION "${clblast_VERSION_MAJOR}.${clblast_VERSION_MINOR}.${clblast_VERSION_PATCH}")
set(clblast_SOVERSION ${clblast_VERSION_MAJOR})
+# Policies
+cmake_policy(SET CMP0074 NEW) # to make -DCBLAS_ROOT= work with newer CMake versions as well
+
# Options and their default values
option(BUILD_SHARED_LIBS "Build a shared (ON) or static library (OFF)" ON)
option(SAMPLES "Enable compilation of the examples" OFF)