summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2016-07-06 21:50:12 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2016-07-06 21:50:12 +0200
commit27854070b4f9ba1d58ccd7189032e56325506597 (patch)
treea2e1b393ad06668f00ac7f5701d53df10a97fb4c /CMakeLists.txt
parent77325b8974e19188fc5afad1447d4df4f9ae30fd (diff)
Added a VERBOSE mode to debug performance: now prints details about compilation and kernel execution to screen
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index adb87658..77d1cd08 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,13 @@ option(TUNERS "Enable compilation of the tuners" OFF)
option(CLIENTS "Enable compilation of the clients to test and compare performance" OFF)
option(TESTS "Enable compilation of the correctness tests" OFF)
+# Compile in verbose mode with additional diagnostic messages
+option(VERBOSE "Compile in verbose mode for additional diagnostic messages" OFF)
+if(VERBOSE)
+ message("-- Building in verbose mode")
+ add_definitions(-DVERBOSE)
+endif()
+
# ==================================================================================================
# RPATH settings