summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCNugteren <web@cedricnugteren.nl>2016-07-04 19:46:14 +0200
committerCNugteren <web@cedricnugteren.nl>2016-07-04 19:46:14 +0200
commit2d665099ef6b14713beb0cac1bd405073a49e791 (patch)
tree51150283880e48043c84646dcdd651141c3e2bcb /CMakeLists.txt
parent9683b50c557c7e415389b321d437be39ce0e519d (diff)
Fixed a linking issue with the tuners on Visual Studio
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 70e4198c..adb87658 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -221,9 +221,15 @@ if(TUNERS)
# Includes CLTune
include_directories(${CLTUNE_INCLUDE_DIRS})
+ # Visual Studio requires the sources of non-exported objects/libraries
+ set(TUNERS_COMMON )
+ if(MSVC)
+ set(TUNERS_COMMON ${TUNERS_COMMON} src/utilities.cpp)
+ endif()
+
# Adds tuning executables
foreach(KERNEL ${KERNELS})
- add_executable(clblast_tuner_${KERNEL} src/tuning/kernels/${KERNEL}.cpp)
+ add_executable(clblast_tuner_${KERNEL} ${TUNERS_COMMON} src/tuning/kernels/${KERNEL}.cpp)
target_link_libraries(clblast_tuner_${KERNEL} clblast ${CLTUNE_LIBRARIES} ${OPENCL_LIBRARIES})
install(TARGETS clblast_tuner_${KERNEL} DESTINATION bin)
endforeach()