summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCNugteren <web@cedricnugteren.nl>2015-06-21 12:57:38 +0200
committerCNugteren <web@cedricnugteren.nl>2015-06-21 12:57:38 +0200
commit4c2a166bc5406b194108d3b31238e55ac6b99e3c (patch)
tree9f136083289546836b810fd7bcb2cad3ad7d6fa3 /CMakeLists.txt
parente3829c1067814c0aa83ab440fa431d98837aeeda (diff)
Added test infrastructure for AB and AC routines
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 19 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 038e71ae..b84ed62b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,7 +98,9 @@ set(SAMPLE_PROGRAMS sgemm)
set(ROUTINES_XY xaxpy)
set(ROUTINES_AXY xgemv)
set(ROUTINES_ABC xgemm xsymm)
-set(ROUTINES ${ROUTINES_XY} ${ROUTINES_AXY} ${ROUTINES_ABC})
+set(ROUTINES_AB )
+set(ROUTINES_AC )
+set(ROUTINES ${ROUTINES_XY} ${ROUTINES_AXY} ${ROUTINES_ABC} ${ROUTINES_AB} ${ROUTINES_AC})
# ==================================================================================================
@@ -172,6 +174,8 @@ if(TESTS)
add_library(test_correctness_xy OBJECT test/correctness/testxy.cc)
add_library(test_correctness_axy OBJECT test/correctness/testaxy.cc)
add_library(test_correctness_abc OBJECT test/correctness/testabc.cc)
+ add_library(test_correctness_ab OBJECT test/correctness/testab.cc)
+ add_library(test_correctness_ac OBJECT test/correctness/testac.cc)
# Compiles the correctness-tests
foreach(ROUTINE ${ROUTINES_XY})
@@ -179,22 +183,32 @@ if(TESTS)
$<TARGET_OBJECTS:test_correctness_common>
$<TARGET_OBJECTS:test_correctness_xy>
test/correctness/routines/${ROUTINE}.cc)
- target_link_libraries(test_${ROUTINE} clBLAS clblast ${OPENCL_LIBRARIES})
- install(TARGETS test_${ROUTINE} DESTINATION bin)
endforeach()
foreach(ROUTINE ${ROUTINES_AXY})
add_executable(test_${ROUTINE}
$<TARGET_OBJECTS:test_correctness_common>
$<TARGET_OBJECTS:test_correctness_axy>
test/correctness/routines/${ROUTINE}.cc)
- target_link_libraries(test_${ROUTINE} clBLAS clblast ${OPENCL_LIBRARIES})
- install(TARGETS test_${ROUTINE} DESTINATION bin)
endforeach()
foreach(ROUTINE ${ROUTINES_ABC})
add_executable(test_${ROUTINE}
$<TARGET_OBJECTS:test_correctness_common>
$<TARGET_OBJECTS:test_correctness_abc>
test/correctness/routines/${ROUTINE}.cc)
+ endforeach()
+ foreach(ROUTINE ${ROUTINES_AB})
+ add_executable(test_${ROUTINE}
+ $<TARGET_OBJECTS:test_correctness_common>
+ $<TARGET_OBJECTS:test_correctness_ab>
+ test/correctness/routines/${ROUTINE}.cc)
+ endforeach()
+ foreach(ROUTINE ${ROUTINES_AC})
+ add_executable(test_${ROUTINE}
+ $<TARGET_OBJECTS:test_correctness_common>
+ $<TARGET_OBJECTS:test_correctness_ac>
+ test/correctness/routines/${ROUTINE}.cc)
+ endforeach()
+ foreach(ROUTINE ${ROUTINES})
target_link_libraries(test_${ROUTINE} clBLAS clblast ${OPENCL_LIBRARIES})
install(TARGETS test_${ROUTINE} DESTINATION bin)
endforeach()