summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2016-03-23 20:31:25 +0100
committerCedric Nugteren <web@cedricnugteren.nl>2016-03-23 20:31:25 +0100
commit706c6987c6044d49770874e5752968a3384a5300 (patch)
tree0f6c788eabf62d5ef5ca65addc1a4ce17ea0e887 /CMakeLists.txt
parentd9356954176eba875138e38b5cf0fb131e1ac925 (diff)
Fixed compilation of the two SGEMM samples
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d26a2843..65debdf4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,6 +73,14 @@ else ()
endif()
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${FLAGS}")
+# C compiler settings (for the sample)
+if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "MSVC")
+ set(CFLAGS "/Ox")
+else ()
+ set(CFLAGS "-O3 -std=c99")
+endif()
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${CFLAGS}")
+
# ==================================================================================================
# Package scripts location