summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2017-07-30 18:52:20 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2017-07-30 18:52:20 +0200
commitb494df111129c669489942aee8d41aa1119f1d9e (patch)
treedd2b836cccbf1b2071e267587a25c385b48569d4 /CMakeLists.txt
parent6ceb9b71526e3a51b71b79e26e05cb14b32472af (diff)
Fixes warnings for Clang & AppleClang
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 049662b4..c78add4e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,8 +101,8 @@ else()
set(FLAGS "${FLAGS} -Wno-missing-prototypes -Wno-float-equal -Wno-switch-enum -Wno-switch")
set(FLAGS "${FLAGS} -Wno-exit-time-destructors -Wno-global-constructors -Wno-missing-noreturn")
set(FLAGS "${FLAGS} -Wno-deprecated-declarations")
- if(NOT CMAKE_CXX_COMPILER_ID MATCHES AppleClang)
- if(CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 3.9.0)
+ if(CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 3.9.0) # clang 4.0 or higher
+ if(CMAKE_CXX_COMPILER_VERSION VERSION_LESS 7.0.0) # but not for AppleClang
set(FLAGS "${FLAGS} -Wno-undefined-var-template")
endif()
endif()