summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2016-02-06 12:48:42 +0100
committerCedric Nugteren <web@cedricnugteren.nl>2016-02-06 12:48:42 +0100
commitbb985f010bb3df88fd240b4e095c462d63248bd9 (patch)
treec6b73493ff2773085e32154d3bd033bf2a56d57b /CMakeLists.txt
parent40346bb3a551f14afa5465d7708d8d31102e475e (diff)
Changed the order of tuners in the alltuners target
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 74b1e9b1..5918d3eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -107,14 +107,14 @@ include_directories(${clblast_SOURCE_DIR}/include ${OPENCL_INCLUDE_DIRS})
# ==================================================================================================
# Sets the supported routines and the used kernels. New routines and kernels should be added here.
-set(KERNELS copy pad transpose padtranspose xaxpy xdot xgemv xgemm)
+set(KERNELS copy pad transpose padtranspose xaxpy xdot xgemm xgemv)
set(SAMPLE_PROGRAMS_CPP sgemm)
set(SAMPLE_PROGRAMS_C sgemm)
set(LEVEL1_ROUTINES xswap xscal xcopy xaxpy xdot xdotu xdotc)
set(LEVEL2_ROUTINES xgemv xgbmv xhemv xhbmv xhpmv xsymv xsbmv xspmv xtrmv xtbmv xtpmv)
set(LEVEL3_ROUTINES xgemm xsymm xhemm xsyrk xherk xsyr2k xher2k xtrmm)
set(ROUTINES ${LEVEL1_ROUTINES} ${LEVEL2_ROUTINES} ${LEVEL3_ROUTINES})
-set(PRECISIONS 32 3232 64 6464)
+set(PRECISIONS 32 64 3232 6464)
# ==================================================================================================