summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2017-12-24 12:10:55 +0100
committerCedric Nugteren <web@cedricnugteren.nl>2017-12-24 12:10:55 +0100
commitbd540829ea1954c3b367ec70aa8c5811b643422b (patch)
treed58a47f265bc256949182172997af7b4d5c6faec /CMakeLists.txt
parent8657e90cf848a827c09b9dd5c3d4c2eab5c7037e (diff)
Fixes for the CUDA backend of CLBlast
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eb2d847d..b0a2759c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -577,7 +577,10 @@ if(TESTS)
endforeach()
# Miscellaneous tests
- set(MISC_TESTS override_parameters preprocessor)
+ set(MISC_TESTS override_parameters)
+ if(NOT CUDA)
+ set(MISC_TESTS ${MISC_TESTS} preprocessor)
+ endif()
if(MSVC)
set(TESTS_COMMON ${TESTS_COMMON} src/kernel_preprocessor.cpp)
endif()