summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCNugteren <web@cedricnugteren.nl>2015-06-11 07:39:23 +0200
committerCNugteren <web@cedricnugteren.nl>2015-06-11 07:39:23 +0200
commitbdc3444d5c96f71e0c27eb8048346dc28e7b38e2 (patch)
treee18dbe82f59c065a2ea142e3cd08e2e4f2a33f3a /CMakeLists.txt
parent16c3bb9140bb2a5a6178e05d4757ada1584cb780 (diff)
Added new tester for matrix-vector-vector routines
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f93079d9..b6697ac3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -96,8 +96,9 @@ include_directories(${clblast_SOURCE_DIR}/include ${OPENCL_INCLUDE_DIRS})
set(KERNELS copy pad transpose padtranspose xaxpy xgemv xgemm)
set(SAMPLE_PROGRAMS sgemm)
set(ROUTINES_XY xaxpy)
+set(ROUTINES_AXY )
set(ROUTINES_ABC xgemm xsymm)
-set(ROUTINES ${ROUTINES_XY} ${ROUTINES_ABC})
+set(ROUTINES ${ROUTINES_XY} ${ROUTINES_AXY} ${ROUTINES_ABC})
# ==================================================================================================
@@ -169,6 +170,7 @@ if(TESTS)
# Creates the common correctness-tests objects (requires CMake 2.8.8)
add_library(test_correctness_common OBJECT test/correctness/tester.cc)
add_library(test_correctness_xy OBJECT test/correctness/testxy.cc)
+ add_library(test_correctness_axy OBJECT test/correctness/testaxy.cc)
add_library(test_correctness_abc OBJECT test/correctness/testabc.cc)
# Compiles the correctness-tests
@@ -180,6 +182,14 @@ if(TESTS)
target_link_libraries(test_${ROUTINE} clBLAS clblast ${OPENCL_LIBRARIES})
install(TARGETS test_${ROUTINE} DESTINATION bin)
endforeach()
+ foreach(ROUTINE ${ROUTINES_AXY})
+ add_executable(test_${ROUTINE}
+ $<TARGET_OBJECTS:test_correctness_common>
+ $<TARGET_OBJECTS:test_correctness_axy>
+ test/correctness/routines/${ROUTINE}.cc)
+ target_link_libraries(test_${ROUTINE} clBLAS clblast ${OPENCL_LIBRARIES})
+ install(TARGETS test_${ROUTINE} DESTINATION bin)
+ endforeach()
foreach(ROUTINE ${ROUTINES_ABC})
add_executable(test_${ROUTINE}
$<TARGET_OBJECTS:test_correctness_common>