summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2017-10-08 21:52:02 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2017-10-08 21:52:02 +0200
commitdf3c9f4a8ab9e82ccc4add15b04da5c1b6172b72 (patch)
tree834d7f481d0370ce5e467e940396ee7c3738eb3c /CMakeLists.txt
parent2bb8402ec15a672eaa26595247aa09f7d88fecdb (diff)
Moved non-routine-specific API functions and includes to separate files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 05e7393b..52accbd4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -182,6 +182,7 @@ set(SOURCES
src/routines/common.cpp
src/utilities/clblast_exceptions.cpp
src/utilities/utilities.cpp
+ src/api_common.cpp
src/cache.cpp
src/clblast.cpp
src/clblast_c.cpp
@@ -201,6 +202,7 @@ set(HEADERS # such that they can be discovered by IDEs such as CLion and Visual
src/routines/level1/xmin.hpp
src/routines/level1/xsum.hpp
src/routines/common.hpp
+ src/routines/routines.hpp
src/utilities/buffer_test.hpp
src/utilities/clblast_exceptions.hpp
src/utilities/device_mapping.hpp