summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2018-07-25 22:59:36 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2018-07-25 22:59:36 +0200
commite8dea34fcee36b6a10762653d3dcaadcb436cb80 (patch)
tree09a672423434da0a03ac5410936ea3d10f018823 /CMakeLists.txt
parent6a8b9e24f2428c140dac97d8279cbb99d051c59d (diff)
Added workaround for weird AMD SI Hainan bug
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fea08287..2a26193d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,12 @@ option(TESTS "Enable compilation of the correctness tests" OFF)
option(NETLIB "Enable compilation of the CBLAS Netlib API" OFF)
option(CUBLAS "Enables performance comparison against cuBLAS on NVIDIA GPUs" OFF)
+# Workarounds for bugs
+option(AMD_HAINAN "Enables workaround for bug in AMD SI Hainan GPUs" OFF)
+if(AMD_HAINAN)
+ add_definitions(-DAMD_HAINAN_WORKAROUND)
+endif()
+
# Select between an OpenCL API (default) or a CUDA API (beta)
option(OPENCL "Build CLBlast with an OpenCL API (default)" ON)
option(CUDA "Build CLBlast with a CUDA API (beta)" OFF)