summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2017-07-12 20:58:31 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2017-07-12 20:58:31 +0200
commitf2477f663672fd37301d6e2ce4646519f71d5cce (patch)
treef82474fc6721be5af3790aa826a5494885576563 /CMakeLists.txt
parentc71362b13d55c200814da3826e515ab729b82e69 (diff)
Removed spurious warning for Clang < 3.9
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 72c03352..595c6b89 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,7 +101,9 @@ else()
set(FLAGS "${FLAGS} -Wno-missing-prototypes -Wno-float-equal -Wno-switch-enum -Wno-switch")
set(FLAGS "${FLAGS} -Wno-exit-time-destructors -Wno-global-constructors -Wno-missing-noreturn")
set(FLAGS "${FLAGS} -Wno-deprecated-declarations")
- set(FLAGS "${FLAGS} -Wno-undefined-var-template")
+ if(CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 3.9.0)
+ set(FLAGS "${FLAGS} -Wno-undefined-var-template")
+ endif()
endif()
endif()
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${FLAGS}")