summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2017-06-27 21:05:16 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2017-06-27 21:05:16 +0200
commit4e51b1e1f8773c7bb386efaf0ccd85fc1ba0904b (patch)
tree98ef95a478dbcf9c0441762462fc14fd80c722fa /CMakeLists.txt
parente60b10529a0548597d2398fb1e55dcbfa6c104e6 (diff)
Moved and inlined some static member variables and disabled spurious clang warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e549a63a..2666e350 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,6 +101,7 @@ else()
set(FLAGS "${FLAGS} -Wno-missing-prototypes -Wno-float-equal -Wno-switch-enum -Wno-switch")
set(FLAGS "${FLAGS} -Wno-exit-time-destructors -Wno-global-constructors -Wno-missing-noreturn")
set(FLAGS "${FLAGS} -Wno-deprecated-declarations")
+ set(FLAGS "${FLAGS} -Wno-undefined-var-template")
endif()
endif()
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${FLAGS}")