summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorcnugteren <web@cedricnugteren.nl>2016-03-30 16:24:38 -0700
committercnugteren <web@cedricnugteren.nl>2016-03-30 16:24:38 -0700
commit6578102ae996ce0aa52b45704f38c1cd5a10d3c0 (patch)
treee02694a1b3d69a706353cfdd271ce4367bd92064 /CMakeLists.txt
parentc1df78676471a8a26ea8ec5a092734566d490db4 (diff)
CMake now downloads the cl.hpp header from the Khronos website when building the samples
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65debdf4..d3ad6889 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -164,6 +164,9 @@ endif()
# This section contains all the code related to the examples
if(SAMPLES)
+ # Downloads the cl.hpp file from Khronos
+ file(DOWNLOAD https://www.khronos.org/registry/cl/api/1.1/cl.hpp ${clblast_SOURCE_DIR}/samples/cl.hpp)
+
# Adds sample programs (C++)
foreach(SAMPLE ${SAMPLE_PROGRAMS_CPP})
add_executable(clblast_sample_${SAMPLE} samples/${SAMPLE}.cc)