summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2016-04-27 16:02:13 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2016-04-27 16:02:13 +0200
commit82be8f211cbd50d2d75fe78d8af4a1da04a0582b (patch)
tree19b4dbb4478edb28b7afd99a11e5a1e470098a5d /CMakeLists.txt
parent44bdb60e834ef015ee4cb25a6f0eba2a092291f0 (diff)
Moved all cache-related functions to a separate file; added a ClearCompiledProgramCache function to clear the cache
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index efdf6be0..6abfc09f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -131,7 +131,8 @@ set(PRECISIONS 32 64 3232 6464)
# ==================================================================================================
# Gathers all source-files
-set(SOURCES src/clblast.cc src/database.cc src/routine.cc src/utilities.cc src/clblast_c.cc)
+set(SOURCES src/clblast.cc src/database.cc src/routine.cc src/cache.cc
+ src/utilities.cc src/clblast_c.cc)
foreach(ROUTINE ${LEVEL1_ROUTINES})
set(SOURCES ${SOURCES} src/routines/level1/${ROUTINE}.cc)
endforeach()