summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2017-08-12 15:38:17 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2017-08-12 15:38:17 +0200
commit844e68853e14e5cf5ba67a8b376bd59d27383290 (patch)
treed948a42b6b08017783ff8814f9b487430a59c0cc /CMakeLists.txt
parentd588f28dbeb3c1906ffced711dc1b55a5bdc5b39 (diff)
Moved some utility functions to a test-specific utility compilation-unit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae259fad..9abdadf3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -380,7 +380,8 @@ endif()
# Section for the performance tests (i.e. the client). These compare against optionally a reference
# library, either clBLAS, a CPU BLAS, or CUDA's cuBLAS.
if(CLIENTS)
- set(CLIENTS_COMMON ${WRAPPERS} test/performance/client.hpp test/routines/common.hpp)
+ set(CLIENTS_COMMON ${WRAPPERS} test/test_utilities.cpp test/test_utilities.hpp
+ test/performance/client.hpp test/routines/common.hpp)
# Visual Studio requires the sources of non-exported objects/libraries
if(MSVC)
@@ -431,7 +432,8 @@ endif()
# CPU BLAS library, and/or cuBLAS to act as a reference.
if(TESTS)
enable_testing()
- set(TESTS_COMMON ${WRAPPERS} test/correctness/testblas.hpp test/correctness/tester.hpp
+ set(TESTS_COMMON ${WRAPPERS} test/test_utilities.cpp test/test_utilities.hpp
+ test/correctness/testblas.hpp test/correctness/tester.hpp
test/routines/common.hpp)
# Visual Studio requires the sources of non-exported objects/libraries