summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2016-10-22 15:36:48 +0200
committerCedric Nugteren <web@cedricnugteren.nl>2016-10-22 15:36:48 +0200
commitb0ff11acf0c857874e518717164eff3ddbabb803 (patch)
tree8d3754380ff5c54a8c929f542949228bf39ae645 /CMakeLists.txt
parent9afbbc9ef92e2d3427f8de0327daa8f4a134adc0 (diff)
Moved files around a bit; created a utilities subfolder
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 17bff79b..04388c6e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -167,12 +167,12 @@ set(PRECISIONS 32 64 3232 6464 16)
set(SOURCES
src/database/database.cpp
src/routines/common.cpp
+ src/utilities/clblast_exceptions.cpp
+ src/utilities/utilities.cpp
src/cache.cpp
src/clblast.cpp
- src/clblast_exceptions.cpp
src/clblast_c.cpp
src/routine.cpp
- src/utilities.cpp
)
foreach(ROUTINE ${LEVEL1_ROUTINES})
set(SOURCES ${SOURCES} src/routines/level1/${ROUTINE}.cpp)
@@ -221,7 +221,7 @@ install(EXPORT CLBlast DESTINATION lib/cmake/CLBLast FILE CLBlastConfig.cmake)
# Install pkg-config file on Linux
if(UNIX)
- configure_file("${CMAKE_CURRENT_SOURCE_DIR}/src/clblast.pc.in"
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/clblast.pc.in"
"${CMAKE_CURRENT_BINARY_DIR}/clblast.pc" @ONLY IMMEDIATE)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/clblast.pc
DESTINATION lib/pkgconfig)