summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCNugteren <web@cedricnugteren.nl>2015-08-09 15:50:41 +0200
committerCNugteren <web@cedricnugteren.nl>2015-08-09 15:50:41 +0200
commitdbdb58c6002cbd693f246f1e93919cc32ad4055a (patch)
treedd2b7b51c9d5baebb3f9ea660c9ba96e7aaef281 /CMakeLists.txt
parente4aa4519c2e2e41d3f8551d4fc8b775e7bf0d168 (diff)
Refactored the tuners, added JSON output
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8ca225b2..72cfe52f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -154,12 +154,9 @@ if(TUNERS)
# Includes CLTune
include_directories(${CLTUNE_INCLUDE_DIRS})
- # Creates the common tuner objects (requires CMake 2.8.8)
- add_library(tuners_common OBJECT src/tuning/tuning.cc)
-
# Adds tuning executables
foreach(KERNEL ${KERNELS})
- add_executable(tuner_${KERNEL} $<TARGET_OBJECTS:tuners_common> src/tuning/${KERNEL}.cc)
+ add_executable(tuner_${KERNEL} src/tuning/${KERNEL}.cc)
target_link_libraries(tuner_${KERNEL} clblast ${CLTUNE_LIBRARIES} ${OPENCL_LIBRARIES})
install(TARGETS tuner_${KERNEL} DESTINATION bin)
endforeach()