summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2018-08-09 21:37:47 +0200
committerGitHub <noreply@github.com>2018-08-09 21:37:47 +0200
commitdd1fa7cc8184223900292939dab2518e6a28a6db (patch)
tree2401badea0664b405e1fd62c0d35395d98eca652 /CMakeLists.txt
parent2bea758165cd8c784d1fafe60a949154c2e10000 (diff)
parent9d9f09fce9d42247701c16d89ca356cdd3a76b4b (diff)
Merge pull request #310 from CNugteren/CLBlast-307-netlib-api-static-opencl-vars
Netlib API with optional static OpenCL variables
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb62ae27..fd201021 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,9 +32,19 @@ option(SAMPLES "Enable compilation of the examples" OFF)
option(TUNERS "Enable compilation of the tuners" ON)
option(CLIENTS "Enable compilation of the clients to test and compare performance" OFF)
option(TESTS "Enable compilation of the correctness tests" OFF)
-option(NETLIB "Enable compilation of the CBLAS Netlib API" OFF)
option(CUBLAS "Enables performance comparison against cuBLAS on NVIDIA GPUs" OFF)
+# The optional Netlib API for CLBlast
+option(NETLIB "Enable compilation of the CBLAS Netlib API" OFF)
+option(NETLIB_PERSISTENT_OPENCL "Makes OpenCL device and context in the CBLAS Netlib API static" OFF)
+if(NETLIB)
+ message("-- Building the Netlib API of CLBlast")
+ if(NETLIB_PERSISTENT_OPENCL)
+ message(" ^^ while using static variables for OpenCL device and context")
+ add_definitions(-DNETLIB_PERSISTENT_OPENCL)
+ endif()
+endif()
+
# Workarounds for bugs
option(AMD_SI_EMPTY_KERNEL_WORKAROUND "Enables workaround for bug in AMD Southern Island GPUs" OFF)
if(AMD_SI_EMPTY_KERNEL_WORKAROUND)