summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-12-22 15:40:27 +0100
committerGard Spreemann <gspr@nonempty.org>2020-12-22 18:37:21 +0100
commit5151b7b35959e46d08f5f73dcda1c33dd8c88bd3 (patch)
tree870e583b327835ee2f030fe488e35960d146e653 /debian
parent7b1d3e5f0a1a36a469905e0b73d48cfea4d1bd46 (diff)
Initial packaging.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/clblast-tests.install1
-rw-r--r--debian/clblast-utils.install1
-rw-r--r--debian/control18
-rw-r--r--debian/copyright6
-rw-r--r--debian/libclblast-dev.install5
-rw-r--r--debian/libclblast1.install1
-rw-r--r--debian/libclblast1.shlibs1
-rwxr-xr-xdebian/rules23
9 files changed, 56 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index d40d8897..9677114c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,5 @@
-clblast (0.1-1) unstable; urgency=medium
+clblast (1.5.1-1) UNRELEASED; urgency=medium
* Initial release (Closes: #XXXXXX)
- -- Gard Spreemann <gspr@nonempty.org> Tue, 22 Dec 2020 15:11:05 +0100
- \ No newline at end of file
+ -- Gard Spreemann <gspr@nonempty.org> Tue, 22 Dec 2020 17:22:05 +0100
diff --git a/debian/clblast-tests.install b/debian/clblast-tests.install
new file mode 100644
index 00000000..ca452daa
--- /dev/null
+++ b/debian/clblast-tests.install
@@ -0,0 +1 @@
+usr/bin/clblast_test_* \ No newline at end of file
diff --git a/debian/clblast-utils.install b/debian/clblast-utils.install
new file mode 100644
index 00000000..36e40000
--- /dev/null
+++ b/debian/clblast-utils.install
@@ -0,0 +1 @@
+usr/bin/clblast_tuner_*
diff --git a/debian/control b/debian/control
index 80c64b18..473f9443 100644
--- a/debian/control
+++ b/debian/control
@@ -5,6 +5,7 @@ Priority: optional
Standards-Version: 4.5.1
Build-Depends: cmake,
debhelper-compat (= 13),
+ libblas-dev,
ocl-icd-opencl-dev | opencl-dev
Rules-Requires-Root: no
Homepage: https://cnugteren.github.io/clblast/clblast.html
@@ -44,6 +45,21 @@ Description: Tuned OpenCL BLAS library (development files)
.
This package provides the static library and headers.
+Package: clblast-tests
+Section: math
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Tests for CLBlast
+ CLBlast is a modern, lightweight, performant and tunable OpenCL BLAS
+ library written in C++11. It is designed to leverage the full
+ performance potential of a wide variety of OpenCL devices from
+ different vendors, including desktop and laptop GPUs, embedded GPUs,
+ and other accelerators. CLBlast implements BLAS routines: basic
+ linear algebra subprograms operating on vectors and matrices.
+ .
+ This package provides tests and benchmarks against other BLAS
+ implementations.
+
Package: clblast-utils
Section: math
Architecture: any
@@ -57,4 +73,4 @@ Description: Utilities for CLBlast
linear algebra subprograms operating on vectors and matrices.
.
This package provides utilities for tuning the implementation for
- specific hardware. \ No newline at end of file
+ specific hardware.
diff --git a/debian/copyright b/debian/copyright
index 549996e1..b3ddf656 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -9,3 +9,9 @@ License: Apache-2.0
Files: debian/*
Copyright: 2020 Gard Spreemann <gspr@nonempty.org>
License: Apache-2.0
+
+License: Apache-2.0
+ The project is licensed under Apache Version 2.0.
+ .
+ On Debian systems, the full text of the license can be found in the file
+ "/usr/share/common-licenses/Apache-2.0".
diff --git a/debian/libclblast-dev.install b/debian/libclblast-dev.install
new file mode 100644
index 00000000..c97725e0
--- /dev/null
+++ b/debian/libclblast-dev.install
@@ -0,0 +1,5 @@
+usr/lib/${DEB_HOST_MULTIARCH}/libclblast.so
+usr/lib/${DEB_HOST_MULTIARCH}/libclblast.a
+usr/include
+usr/lib/${DEB_HOST_MULTIARCH}/pkgconfig
+usr/lib/${DEB_HOST_MULTIARCH}/cmake
diff --git a/debian/libclblast1.install b/debian/libclblast1.install
new file mode 100644
index 00000000..d1b958c4
--- /dev/null
+++ b/debian/libclblast1.install
@@ -0,0 +1 @@
+usr/lib/${DEB_HOST_MULTIARCH}/libclblast.so.* \ No newline at end of file
diff --git a/debian/libclblast1.shlibs b/debian/libclblast1.shlibs
new file mode 100644
index 00000000..5a98f456
--- /dev/null
+++ b/debian/libclblast1.shlibs
@@ -0,0 +1 @@
+libclblast 1 libclblast1 (>= 1.5.1)
diff --git a/debian/rules b/debian/rules
index 5f0b58f0..5e19087e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,27 @@
#!/usr/bin/make -f
-#export DH_VERBOSE = 1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+FLAGS:=-DCUBLAS=false -DCUDA=false -DNETLIB=false -DOPENCL=true
%:
dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure --builddirectory=build-static -- -DBUILD_SHARED_LIBS=false -DTUNERS=false -DTESTS=false $(FLAGS)
+ dh_auto_configure --builddirectory=build -- -DBUILD_SHARED_LIBS=true -DTUNERS=true -DTESTS=true $(FLAGS)
+
+override_dh_auto_build:
+ dh_auto_build --builddirectory=build-static
+ dh_auto_build --builddirectory=build
+
+override_dh_auto_clean:
+ dh_auto_clean --builddirectory=build-static
+ dh_auto_clean --builddirectory=build
+
+override_dh_auto_install:
+ dh_auto_install --builddirectory=build-static
+ dh_auto_install --builddirectory=build
+
+override_dh_missing:
+ dh_missing --list-missing