summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG1
-rw-r--r--CMakeLists.txt5
-rw-r--r--README.md1
3 files changed, 4 insertions, 3 deletions
diff --git a/CHANGELOG b/CHANGELOG
index d018e211..8fce1969 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -8,6 +8,7 @@ Development version (next release)
- Fixed a performance issue (caused by fp16 support) by optimizing alpha/beta parameter passing to kernels
- Added an option (-warm_up) to do a warm-up run before timing in the performance clients
- Improved performance significantly of rotated GEMV computations
+- Various minor fixes and enhancements
- Added tuned parameters for various devices (see README)
Version 0.8.0
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 231b8e95..7393c6e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -230,8 +230,6 @@ endif()
# the CLTune library (not included as part of the source).
if(TUNERS)
- # Includes CLTune
-
# Visual Studio requires the sources of non-exported objects/libraries
set(TUNERS_COMMON )
if(MSVC)
@@ -301,7 +299,8 @@ if(CLIENTS)
else()
# Creates the common performance-tests objects (requires CMake 2.8.8)
add_library(test_performance_common OBJECT test/performance/client.cpp)
- # Adds clblast's interface include pathes because we can't link to clblast here
+
+ # Adds CLBlast's interface include paths because we can't link to CLBlast here
target_include_directories(test_performance_common PRIVATE
$<TARGET_PROPERTY:clblast,INTERFACE_INCLUDE_DIRECTORIES>
${clblast_SOURCE_DIR})
diff --git a/README.md b/README.md
index 1b3adcb9..d9d30cb1 100644
--- a/README.md
+++ b/README.md
@@ -286,6 +286,7 @@ The contributing authors (code, pull requests, testing) so far are:
* [Marco Hutter](https://github.com/gpus)
* [Hugh Perkins](https://github.com/hughperkins)
* [Gian-Carlo Pascutto](https://github.com/gcp)
+* [Ivan Shapovalov](https://github.com/intelfx)
Tuning and testing on a variety of OpenCL devices was made possible by: