summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG2
-rw-r--r--CMakeLists.txt2
-rw-r--r--README.md2
-rw-r--r--samples/sasum.c2
4 files changed, 4 insertions, 4 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 51f529d3..c77e5e48 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,5 +1,5 @@
-Development version (next release)
+Version 0.7.0
- Added exports to be able to create a DLL on Windows (thanks to Marco Hutter)
- Made the library thread-safe
- Performance and correctness tests can now (on top of clBLAS) be performed against CPU BLAS libraries
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d63105e4..44524537 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,7 @@
cmake_minimum_required(VERSION 2.8.10)
project("clblast" C CXX)
set(clblast_VERSION_MAJOR 0)
-set(clblast_VERSION_MINOR 6)
+set(clblast_VERSION_MINOR 7)
set(clblast_VERSION_PATCH 0)
# Options and their default values
diff --git a/README.md b/README.md
index ae236622..8d9220a6 100644
--- a/README.md
+++ b/README.md
@@ -84,7 +84,7 @@ Or alternatively the plain C version:
#include <clblast_c.h>
-Afterwards, any of CLBlast's routines can be called directly: there is no need to initialize the library. The available routines and the required arguments are described in the `clblast.h` include file. Additionally, a couple of stand-alone example programs are included in `samples/`.
+Afterwards, any of CLBlast's routines can be called directly: there is no need to initialize the library. The available routines and the required arguments are described in the `clblast.h` include file and the included [API documentation](doc/api.md). Additionally, a couple of stand-alone example programs are included in `samples/`.
Using the tuners (optional)
diff --git a/samples/sasum.c b/samples/sasum.c
index 3b20d301..3fdbb0eb 100644
--- a/samples/sasum.c
+++ b/samples/sasum.c
@@ -79,7 +79,7 @@ int main(void) {
clEnqueueReadBuffer(queue, device_output, CL_TRUE, 0, 1*sizeof(float), host_output, 0, NULL, NULL);
// Example completed. See "clblast_c.h" for status codes (0 -> success).
- printf("Completed SASUM with status %d: %d * |%.1lf| = %.1lf\n", status, n, input_value, host_output[0]);
+ printf("Completed SASUM with status %d: %zu * |%.1lf| = %.1lf\n", status, n, input_value, host_output[0]);
// Clean-up
free(platforms);