summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/pyclblast/README.md8
-rw-r--r--src/pyclblast/setup.py2
2 files changed, 9 insertions, 1 deletions
diff --git a/src/pyclblast/README.md b/src/pyclblast/README.md
index 2f6ebed7..a6a55907 100644
--- a/src/pyclblast/README.md
+++ b/src/pyclblast/README.md
@@ -30,6 +30,14 @@ After installation OpenCL and CLBlast, simply use pip to install PyCLBlast, e.g.
To start using the library, browse the [CLBlast](https://github.com/CNugteren/CLBlast) documentation or check out the PyCLBlast samples provides in the `samples` subfolder.
+For developers, first install CLBlast, followed by the Python requirements (e.g. in a Python3 virtualenv):
+
+ pip install Cython numpy pybind11
+ pip install pyopencl
+
+And then compile the library from this location using the `setup.py` file:
+
+ python setup.py install
Testing PyCLBlast
-------------
diff --git a/src/pyclblast/setup.py b/src/pyclblast/setup.py
index 65aeca3a..1c1bf3ab 100644
--- a/src/pyclblast/setup.py
+++ b/src/pyclblast/setup.py
@@ -22,7 +22,7 @@ ext_modules.append(
setup(
name="pyclblast",
- version="1.1.0",
+ version="1.2.0",
author="Cedric Nugteren",
author_email="web@cedricnugteren.nl",
url="https://github.com/CNugteren/CLBlast/blob/master/src/pyclblast",