summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt2
-rw-r--r--README.md2
-rw-r--r--test/correctness/tester.cc4
3 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5cad6d45..691ca40e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -313,7 +313,7 @@ if(TESTS)
foreach(ROUTINE ${ROUTINES})
target_link_libraries(clblast_test_${ROUTINE} clblast ${REF_LIBRARIES} ${OPENCL_LIBRARIES})
install(TARGETS clblast_test_${ROUTINE} DESTINATION bin)
- add_test(clblast_test_${ROUTINE} clblast_test_${ROUTINE})
+ add_test(clblast_test_${ROUTINE} clblast_test_${ROUTINE} ${DEVICEPLATFORM})
endforeach()
# Adds 'alltests' target: runs all tests
diff --git a/README.md b/README.md
index 41d97fb6..926bc021 100644
--- a/README.md
+++ b/README.md
@@ -156,7 +156,7 @@ To make sure CLBlast is working correctly on your device (recommended), compile
cmake -DTESTS=ON ..
-Afterwards, executables in the form of `clblast_test_xxxxx` are available, in which `xxxxx` is the name of a routine (e.g. `xgemm`). Note that CLBlast is best tested against [clBLAS](http://github.com/clMathLibraries/clBLAS) for correctness. If the library clBLAS is not installed on your system, it will use a regular CPU BLAS library to test against. If both are present, setting the command-line option `-clblas 1` or `-cblas 1` will select the library to test against for the `clblast_test_xxxxx` executables.
+Afterwards, executables in the form of `clblast_test_xxxxx` are available, in which `xxxxx` is the name of a routine (e.g. `xgemm`). Note that CLBlast is tested for correctness against [clBLAS](http://github.com/clMathLibraries/clBLAS) and/or a regular CPU BLAS library. If both are installed on your system, setting the command-line option `-clblas 1` or `-cblas 1` will select the library to test against for the `clblast_test_xxxxx` executables.
Compiling the performance tests/clients (optional)
diff --git a/test/correctness/tester.cc b/test/correctness/tester.cc
index 903e70c1..68c02da6 100644
--- a/test/correctness/tester.cc
+++ b/test/correctness/tester.cc
@@ -45,8 +45,8 @@ Tester<T,U>::Tester(int argc, char *argv[], const bool silent,
// Determines which reference to test against
#if defined(CLBLAST_REF_CLBLAS) && defined(CLBLAST_REF_CBLAS)
- compare_clblas_ = GetArgument(argc, argv, help_, kArgCompareclblas, 1);
- compare_cblas_ = GetArgument(argc, argv, help_, kArgComparecblas, 0);
+ compare_clblas_ = GetArgument(argc, argv, help_, kArgCompareclblas, 0);
+ compare_cblas_ = GetArgument(argc, argv, help_, kArgComparecblas, 1);
#elif CLBLAST_REF_CLBLAS
compare_clblas_ = GetArgument(argc, argv, help_, kArgCompareclblas, 1);
compare_cblas_ = 0;